2
$\begingroup$

I have this: a plane, as you can see.

enter image description here

Object mode:

enter image description here

And a Curve:

enter image description here

When I try to create a rolling mat effect, using the curve modifiers, the plan is deform like this:

enter image description here

enter image description here

What I want is to keep the mat dimensions. Thanks.

$\endgroup$
3
$\begingroup$

Check the radius of each control point of your curve and set them to 1. You can select all of them and set the "mean radius".

Most likely you scaled down or up your curve then applied the transform. This actually keeps the curve at the same position but changes the radius of each control point.

enter image description here

Note : You can deactivate the use of the radius of control points altogether by toggling "radius" in the curve properties. That means any deformation using this curve will consider every control point with a radius of 1 :

enter image description here

|improve this answer|||||
$\endgroup$
  • 1
    $\begingroup$ I'm not the OP, but thanks for the explanation! I finally understand why sometimes my mean radius is at 200, even though it should go only up to 100. $\endgroup$ – Jachym Michal Jan 27 at 8:53
  • 1
    $\begingroup$ Yes that's a bit confusing. I have added additional info if you want to keep the small "V" lines along the resolution points when playing with a small curve. just deactivate the "radius" checkbutton in the curve settings. $\endgroup$ – Gorgious Jan 27 at 9:06
  • 1
    $\begingroup$ Thanks @Gorgious! Your the man!!!! $\endgroup$ – Elbert Villarreal Jan 30 at 2:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.