0
$\begingroup$

Can somebody explain whats wrong with my mesh? Have no idea what to do.

Why some of these faces are transparent? It is rendered with strange holes in Eevee, but in Cycles all is ok.

3rd and 4th screenshots with marked edges

You can achieve this with any texture in my .blend file.

http://pasteall.org/blend/index.php?id=52822

Please help!

enter image description here enter image description here enter image description here enter image description here

$\endgroup$
1
$\begingroup$

You have an Alpha sorting issue. (Z fighting) When you have an Alpha channel in your texture the renderer has problems sorting which face is closest to the camera (or viewer).

This can be corrected if you tell the renderer to ignore Transparency or Backfaces.

First screenshot shows your present alpha Blend Mode :

enter image description here

You have a choice, either set the Blend Mode to Opaque : enter image description here

or deselect the option Show Backface : enter image description here

Third option create a new material and assign that to your model. The default settings work as is.

BTW. Your model also shows Alpha sorting issues in Cycles (and Eevee, when Viewport Shading is set to Material View.

enter image description here

$\endgroup$
2
  • $\begingroup$ Oh Dude, thank you so much! $\endgroup$ – Captain Saturnus Jan 26 '20 at 17:47
  • $\begingroup$ your welcome :) $\endgroup$ – 3fingeredfrog Jan 26 '20 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.