So I made some hair in blender using cycles and as soon as i hit animate (the play button in the time line) it strongly resembles her standing in a pool of water with a live overhead powerline in it.

Obviously I am missing a setting here some place.

(video included.)


  • $\begingroup$ I've tried playing with all sorts of settings. and also set up a hair on another model using the same settings and it all behaves as it should. I'm lost! this is going to be one of my main characters so I would really like to get this fixed. $\endgroup$
    – Aedonix
    Oct 7 '14 at 22:14
  • $\begingroup$ put the subdivision modifier under the particle system $\endgroup$
    – user15052
    Jun 16 '15 at 20:35

I struggled with the same problem. Here is my example:

enter image description here

In my case I set up the hair settings, and then realized that the mesh isn't perfect. Then I tried to remove doubles, and change the geometry. Every time you change geometry (actions like: deleting, separating, ripping vertices) with the hair settings set up, you may see this problem appear.

My advice is to (before setting up the hair):

  1. Apply rotation, location and scale. Ctrl A
  2. Remove doubles.
  3. Apply mirror modifier.
  4. Recalculate normals. Ctrl N
  5. Check the mesh using "mesh lint addon" and make sure the mesh is 'clear' (has no ngons and interior faces).

After applying all the things mentioned above my problem was solved.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.