I know that this is a usual question and might already have an answer online, but I am stuck at UV unwrapping for a lot of time already and i want to explain my issue in detail.

I want to add textures from an image onto a few cubic meshes i have, mostly the front face. I unwrapped the cube in blender and added a image to and it looks good in the texture window, but as soon as i enter object mode or rendered the image is no more and the cube is showing the material only and not the image. I have already assigned the image texture with UV coordinates to the cube still it doesn't show up on object mode. Please help me..

  • $\begingroup$ Are you using BI or cycles? Is it possible you could upload your .blend? $\endgroup$ – gandalf3 Oct 6 '14 at 8:09
  • $\begingroup$ Hey i can get the image in my object mode now, but when i switch to solid view it disappears again. texture view -postimg.org/image/72mubr5yd Solid view -postimg.org/image/pwd8mhtk5 $\endgroup$ – Imakeitblend Oct 6 '14 at 8:36
  • $\begingroup$ Solid view doesn't display textures by default, use textured view, material view, rendered view, or enable Textured solid in 3D view > Properties region (N) > Shading. $\endgroup$ – gandalf3 Oct 6 '14 at 8:38
  • $\begingroup$ Hey, thank you so much. I can now atleast see it in solid view, but how can i ensure it will show up if i import it into unity 3d. $\endgroup$ – Imakeitblend Oct 6 '14 at 8:42
  • $\begingroup$ If you got it this far, it should be exported okay. The rest is on unity's end, see blender.stackexchange.com/q/306/599. $\endgroup$ – gandalf3 Oct 6 '14 at 8:43

In order to make a UV Mapped image appear in Object Mode, I found it was necessary to both:

  • Set the Viewport Shading mode (The button just to the right of the Edit/Object mode selector in 3D View) to "Texture Mode"
  • Set Properties -> Shading (game_settings.material_mode) to GLSL (OpenGL Shading Language)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.