1
$\begingroup$

After adding joints on my model, I imported it as an .fbx file into Blender 2.8 to create an assembly animation. But when Blender opens the file, there are multiple dotted lines which are centered in point, also there are lines (I found out they are called "empty") that I can not remove without messing up the positions of the objects. I removed the joint in Fusion and tried again, but they're still there. Do you know how can I fix this problem?i put a screenshot down below

$\endgroup$
0
2
$\begingroup$

The dotted lines are relationship lines. They mean that one of the object is the parent of the other, which in turns means that if you transform (move, rotate, scale) the parent object, all its child objects will have the same transformation applied. You can "unparent" objects by selecting them and then using either :

  • The shorcut ALT + P then choosing "Clear and keep transformations"
  • Object (top or bottom bar of you 3d view) > Parent > "Clear and keep transformations"

Then, the relation lines should disappear and you can freely delete your empties.

I would advise selecting ALL your objects in the scene and unparenting them all at once while keeping their transform.

$\endgroup$
5
  • $\begingroup$ thanks! doted lines dissepared but the lines (right side of the image) are still there, do you know the reason? thanks again $\endgroup$
    – melisa
    Jan 23 '20 at 13:29
  • $\begingroup$ Do you mean the crosses ? They are the empties. They are a conceptual object which can serve as parent for example or to transform other objects with certain tools in blender. If they are unparented you can simply select them and delete them with the "x" or "del" key $\endgroup$
    – Gorgious
    Jan 23 '20 at 13:37
  • $\begingroup$ when ı select and delete them all the objects move somewhere else, but ı unparented them just as you said, i don't get why it doesn't seem to effects it $\endgroup$
    – melisa
    Jan 23 '20 at 13:45
  • $\begingroup$ Could you upload your file on blend-exchange.giantcowfilms.com and paste the link in your question so I can look at it ? $\endgroup$
    – Gorgious
    Jan 23 '20 at 13:48
  • $\begingroup$ I'm doing an internship in a firm now so unfortunately i can't share the files :( $\endgroup$
    – melisa
    Jan 23 '20 at 13:51
1
$\begingroup$

Could they be relationship lines? Removing dotted assist lines? Problem only occurs when Appending!

If you're using 2.8, the option is on the top right of your 3D window with a drop down arrow next to a symbol with two circles interlaced.enter image description here

Good luck OP :)

$\endgroup$
2
  • $\begingroup$ thank you very much! $\endgroup$
    – melisa
    Jan 23 '20 at 13:27
  • $\begingroup$ No worries :) I literally searched for that yesterday haha. First time I'm using 2.8 and hadn't used blender in years, feels good to be modelling again. Remember to pick one of the answers as accepted so that people know this thread has been resolved (; $\endgroup$
    – Wildmind
    Jan 23 '20 at 13:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.