0
$\begingroup$

I have literally no light settings available. I have the same problem with material settings. Almost all of my material settings are gone also. It works fine on an older saved file. Also works fine if I create a new file. All light sources in this scene display ZERO settings such as color, power, radius. :(

What did I do to make them disappear? I have tried everything and searched to no avail. Unfortunately, none of the suggestions has fixed it so far.

I have also downloaded and reinstalled 2.81 with no difference.

enter image description here

$\endgroup$
2
  • $\begingroup$ is it also a problem with other light types? What happens if you add a new light to the scene? What happens in a newly created file? $\endgroup$
    – Luciano
    Jan 22, 2020 at 9:22
  • $\begingroup$ Yes, this happens with all light types in the scene, both old ones and newly added ones. A new file works just fine though. All settings available. $\endgroup$
    – user87368
    Jan 22, 2020 at 22:29

6 Answers 6

2
$\begingroup$

Actually you should check if you are using Workbench Render Engine, Because it does not support light properties.

enter image description here

enter image description here

You need to use:

1- Eevee Render Engine

2- Cycles Render Engine

enter image description here

$\endgroup$
1
$\begingroup$

visible

That happens when you have hidden "layers" in an old version of Blender and open it with 2.8x. To show the items click the tv and camera-icons to make everything visible again.

See the second image, click the tv-screen and everything is visible again.

enter image description here

$\endgroup$
1
  • $\begingroup$ Thanks, but unfortunately, this didn't work. That changes the visibility in the viewport not the visibility of the settings. $\endgroup$
    – user87368
    Jan 22, 2020 at 22:27
0
$\begingroup$

Not a 100% on this, but blender deletes unused data, this might have happened to your sun enter image description here

Checking this dropdown might give you some extra info on what's happening.

$\endgroup$
1
  • $\begingroup$ Thanks, All of my light sources appear in the dropdown. $\endgroup$
    – user87368
    Jan 22, 2020 at 22:28
0
$\begingroup$

OK, I figured it out. It works fine in all modes except MODELING mode. UV editing, Layout, rendering, compositing modes, all work fine. This does not seem right. Is this a bug? Should I report it as a bug?

Could someone verify that this happens to them also?

$\endgroup$
1
  • $\begingroup$ Can you share the Blend-file? $\endgroup$
    – Jaco
    Jan 23, 2020 at 10:12
0
$\begingroup$

Finally, SOLVED, I still do not know what caused it, but I right clicked on the modeling tab, deleted it, and then added it back. Everything now works normally.

$\endgroup$
0
$\begingroup$

I fixed this issue in version 2.93 by switching render engines. While using Workbench I was unable to view settings for objects and lights.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.