1
$\begingroup$

How do you set the default settings of the Viewport camera (the 'camera' that allows you to see into a viewport as you open blender.)(NOT 3D scene camera)? Because of our workflow in the office I have to change the default units and that result in the scene camera zoomed way in and when I dolly out the whole scene disappears because the clip limits are now super small! I know to change the properties of this camera in the'View' dropdown on the RHS of the 3D window but that is not a setting that 'sticks'? Where can i set those default values? Is it in preferences somewhere? Thanks

EDIT: Attached test .blend file

So the 'Save as Startup' cameras are fine (see below):

enter image description here

But when I change any other window to a 3D viewport (ie: the Shader Editor, below) the camera in that view reverts to the not very useful 'default' 50mm. It's that 'default' I want to change.

enter image description here

Thanks

$\endgroup$
  • 2
    $\begingroup$ After making those changes to the viewport camera, go to File > Defaults > Save Startup File $\endgroup$ – stphnl329 Jan 21 at 14:28
  • $\begingroup$ One would think so, but with every new 3D Viewport you create / drag out (as we need to do in our workflow) it defaults back to the stock factory setting camera. So, no, unfortunately that is not a solution to this issue. $\endgroup$ – JKCapeTown Jan 21 at 14:41
  • $\begingroup$ Hello :). I cannot seem to reproduce your issue in Blender 2.81. When i change the viewport camera to 85mm, all newly created viewports use 85mm. Would you mind sharing your empty .blend file? $\endgroup$ – Jachym Michal Jan 21 at 14:50
  • 1
    $\begingroup$ @ᴊᴀᴄʜʏᴍᴍɪᴄʜᴀʟ I think he means when they create new Workspaces or are splitting areas rather than just starting a new file $\endgroup$ – stphnl329 Jan 21 at 14:55
  • $\begingroup$ @stphnl329 Well, in both of these cases it works just fine. Just tested it. Newly created workspace gets settings from the startup file, so your solution still applies :). $\endgroup$ – Jachym Michal Jan 21 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.