2
$\begingroup$

I have made an aquarium with some youtube help then rendered to see if it's Ok (and it's not).

My video to check: https://www.youtube.com/watch?v=J6HydYXtbdk&feature=youtu.be

You can see on the video that it's flickering (like the bottom of the aquarium). I don't know why it's happening.

My render settings are FFMPEG VIDEO with 30 fps.

$\endgroup$
1
0
$\begingroup$

I'm assuming you are using Blender 2.80+. This is most likely caused by either the lighting, or the fact that you are using EEVEE to render. Now EEVEE is not bad, but there are some settings it uses that produce this kind of look if not adjusted. I would recommend that You use Cycles to render. Settings to change the renderer are in the render tab in the properties section. Now changing the materials to different colors and shaders should fix your problem.

$\endgroup$
1
$\begingroup$

A slight modification of Laurent Roro's solution worked for me. I changed camera Clip End first, but the flickering remained the same. I then changed camera Clip Start, and the flickering completely disappeared. My scene had objects from a little over 100 feet from the camera to 7 miles back, so the default (?) setting of just over zero for Clip Start apparently caused a lot of flickering on the distant objects.

Update: In reply to Ben's inquiry, while I don't have the scene in front of me right now for exact numeric values, I lowered the Clip End to a little beyond the farthest object. Like I said, that didn't really change anything for me. I just now opened Blender on my work machine, and I see that the camera defaults to a Clip Start of .328 feet. I'm guessing the reason mine started out far lower might be a result of importing the camera from After Effects. Anyhow, I changed Clip Start to 100 feet, since the nearest object was at 140 feet or so (can't recall). My reasoning was that it might be similar to the old shadow maps in Blender internal, but that's not a very scientific line of reasoning, or an explanation. Anyhow, the difference was dramatic. I had a particular, low roughness tower in the background that had been flickering like crazy, such that the entire tower basically changed shades of gray from frame to frame.

$\endgroup$
1
  • $\begingroup$ Would be useful (though not essential) to know whether you needed to increase or decrease each value, and since you've given some numeric values for your scene, it might also be helpful to know what numeric values you used for that scene that made it work. $\endgroup$
    – Ben
    Nov 2 '20 at 18:58
0
$\begingroup$

Sounds like Evee render.. Would say please try adjust and tweak your lights and the shadow Parameter but It looks like lightbleeading in Evee or shadow flickering . you can try to use Lightprobe and refletiv maps they are special designed for Evee for a stabil and better lock . But the rendertime increases massiv Have a look here How do the new light probes in Eevee work? How do the new light probes in Eevee work? Another User try to use and explore Evee again ...

$\endgroup$
0
$\begingroup$

You can actually fix in eevee : in camera setting, change "clip end" to a lower value.

This has absolutely nothing to do with lighting, you can look for z-fighting.

$\endgroup$
2
  • 2
    $\begingroup$ Hello, can you give as more info how lower "clip end" affects this flickering in render or how it solves z-fighting? Thank you $\endgroup$
    – vklidu
    Oct 29 '20 at 14:16
  • $\begingroup$ Adjusting clip start and end in camera settings worked to fix my flickering issues. No need to switch to Cycles! Thank you! $\endgroup$ Mar 3 at 20:27
0
$\begingroup$

Increasing the number of samples to 256 in Volumetric setting in Eevee render tab helped me to get rid of the flickering.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.