1
$\begingroup$

I got two steers that are physically the same, both of them are parented to an Empty which is rotated in X axis, but both rotate differently when I see them from camera point of view (while holding R), in this picture you can see how the top one (steer 1) rotates 90 degrees in Y axis while X and Z remains in 0. In the other hand, the lower one behaves completely different, it rotates 90 degrees in Z axis while X and Y values are also being changed:

enter image description here Here is the blend file: https://puu.sh/F1GTy/12964c9a79.blend

The real problem with this is that I'm building a game with working steers and using only Y axis to rotate completely simplified my life, sadly the guy who did the steer that rotates correctly at Y axis is now unreachable. Now all I want to do now is to imitate that behavior, all the steers I made are suffering from this issue. I've already tried clearing Scale, Rotation, Position, etc, getting this problem with the steer that was supposed to work fine made me to ask for help.

$\endgroup$
3
$\begingroup$

I've fixed it for you.

You needed to keep the Y-axes of the steering wheel aligned to the direction perpendicular to the plane of rotation (shown below). The purpose of parenting the steering wheel to the empty was so the axis of the steering wheel stayed aligned for your desired rotation axis.

enter image description here

All I needed to do was to enable Transform Only > Origins, and Face Snapping with Align Rotation to Target then snap the origin onto that flat panel in the middle of the steering wheel. This allowed me to realign the origin of the steering wheel with the normals of that surface. However, this places the Z-axis in the direction you wanted the Y-Axis, so I just rotated it 90 degrees about the X-axis.

Then, just to make sure I didn't move the origin, I pressed Shift+S, Selection to cursor. (The 3D cursor was conveniently already at the origin's original location)

enter image description here enter image description here

Edit: Alternative metohd for pre 2.81

Rotate the empty box back to 0 degrees for all axes. This will bring the steering wheel back into an orientation where the global Y-axis matches up with the desired rotational axis. Unparent the steering wheel with Alt+P, and press Ctrl+A and Apply rotation to the steering wheel. Then you can reparent the wheel to the empty and it should work as intended.

| improve this answer | |
$\endgroup$
  • $\begingroup$ It appears the OP is using 2.7x. $\endgroup$ – batFINGER Jan 20 at 3:07
  • $\begingroup$ @batFINGER How did I not notice that...welp $\endgroup$ – stphnl329 Jan 20 at 3:11
  • $\begingroup$ Updated with another method to fix for pre 2.81 builds. $\endgroup$ – stphnl329 Jan 20 at 3:15
  • $\begingroup$ thank you very much!! it worked perfectly! (and yes, i was using 2.79) $\endgroup$ – Shuuichi Jan 20 at 3:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.