0
$\begingroup$

I am trying to render a glass material on a cup. But it looks grey after rendering. Screenshot of the render. (https://i.stack.imgur.com/cNMEc.png)

The material details are as shown.Material details.(https://i.stack.imgur.com/H8Z84.png)

$\endgroup$
  • 1
    $\begingroup$ You have better chances of getting a answers if all of the information is visible in this page, instead of asking users go through links just to understand your question. Use the tools on the site to upload images directly. See How to upload an image to a post? Please use the edit link at the bottom of your question to modify it (i.stack.imgur.com/lXFuK.png). $\endgroup$ – user1853 Jan 19 at 18:08
  • $\begingroup$ Make sure that the normals are facing in the right direction, screen space reflection should be enabled (Render Properties) and screen space refraction (Material Properties) as well. You should also have something in the environment that the glass can reflect, e.g. other objects or an environment map. $\endgroup$ – Robert Gützkow Jan 19 at 18:45
1
$\begingroup$

Your issue is with the render settings. By default, Eevee does not calculate Screen Space Reflections, effectively disabling translucent/transparent materials.

You have two options, change to the Cycles render engine, or stick with Eevee and enable Screen Space Reflections and Refraction

enter image description here

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Enabling the screen space reflection in Several did not help. However there is no penitentiary with cycles renderer. $\endgroup$ – Shreyas K K Jan 23 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.