1
$\begingroup$

I'd love to be able to preview the alpha value of a material in the 3d viewport, but I can't figure out how to do it.

I add a material and animate it:

  • Assign a material to the default cube
  • Enable transparency for the material
  • Insert a keyframe for Alpha value (Z Transparency)
  • Move the timeline to 20
  • Set the alpha value to 0
  • Insert another keyframe for the Alpha value

I have enabled GLSL shading in the viewport properties and Texture viewport shading in the panel. When I scrub to frame 10 the Alpha value of the material is 0.5, yet it is still fully opaque in the viewport. I can render the frame and see that the material is semi-transparent. Oddly, if I toggle some Material options (e.g. Traceable), the material is displayed as expected in the viewport, but when I scrub the timeline (or alt-a to play) it isn't updated.

I'm not sure if this is a bug, or if I'm just leaving out some setting to trigger the update of the viewport display. I've tested with 2.71 and 2.72 using both an Intel and an Nvidia GPU.

$\endgroup$
1
  • $\begingroup$ Was trying with the wrong blender version, my bad. $\endgroup$
    – user2859
    Oct 4, 2014 at 20:41

0

Browse other questions tagged or ask your own question.