2
$\begingroup$

enter image description hereI am currently learning to work with blender, and i have a problem. By assigning faces to new material it turns transparent and there is nothing i can do. How to solve this problem?

enter image description here

$\endgroup$
3
  • $\begingroup$ It is usual to say that you assign materials to faces, not faces to materials and actually that is what happens - an index value is assigned to a face and then it matches a material slot that has a material assigned to it. So it is transparent in the viewport but not when rendering, right? Could you post some screenshots? $\endgroup$ Jan 19 '20 at 10:52
  • $\begingroup$ Lietuvis? gali gal padėt? $\endgroup$
    – Vygintas
    Jan 19 '20 at 11:04
  • 3
    $\begingroup$ Yes, I am lithuanian, but the language of BSE is English, so it would be better if we stick to it so we don't seem rude to other members of this community. $\endgroup$ Jan 19 '20 at 12:07
1
$\begingroup$

I would check the transparency blend mode settings of the material in the Properties Editor, Material tab:

Picture of transparency blend mode settings

You don't have these settings visible if you have Cycles selected as the render engine, but EEVEE is used to display stuff in the viewport, so just in case they are not there, just switch the render engine to EEVEE temporarily:

Picture of render engine selection

Also check face orientation: enter image description here

Red would mean that normals are inverted.

$\endgroup$
1
$\begingroup$

@Vygintas I was working on that same sushi tutorial when I ran into this problem. It turns out it's a known issue when using multiple materials with a number of older GeForce, Quadro and other end of life graphics cards even though they seem to meet the minimum requirements.

Blender Known Issue: Drawing error with multi-material object. Faces disappear or showing artifacts with 2 or more material slots applied to same object. When trying to use a second material or more on an object, the faces where it is applied become transparent or in some cases they are distorted as black rectangles that stretch to the origin (this second occurs above all with more complex models than a cube). It happens in Blender 2.81 as well as in Blender 2.82, but in Blender 2.80 there is no such error.

While the bug report lists multiple cards, the list is not exhaustive (I have this issue on my card, the GeForce 9800 GTX+, which is not listed). The core issue is the recentness of the video driver. In the case of NVIDIA GPUs, they have to be able to run NVIDIA drivers greater than v400. The highest driver that I can install on my GeForce 9800 GTX+ is GeForce v342.01.

I can confirm that as listed in the bug report, I can use multiple materials in Blender 2.80 and was able to finish the tutorial without a problem!

I like the colors you chose for your tuna and salmon in the above screenshots!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.