1
$\begingroup$

There are black tris all over the mesh with the Ambuient Occlusion node connected. Changing distance or samples does not help.

The subsurface modifier reduces black tris a litte but they are still visible. Can this mesh be fixed somehow? There are no doubles and normals are recalculated. Thanks!

enter image description here

With subsurf: enter image description here

$\endgroup$
5
$\begingroup$

Nate suggested that you change the Auto Smooth value but in your file, this value panel is greyed out. This is because you have Custom Split Normals on your mesh.

enter image description here

Hit the Clear Custom Split Normals Data button and then try reducing the Auto Smooth Angle to something like 12 to 15 and that hopefully will clear your AO artifacts problem.

enter image description here

Edited to propose a different "solution"

I have no idea why but when moving the mesh and its origin to the World Origin a lot of the problem disappears! Perhaps someone can explain why? enter image description here

After separating (P) a small part of the original model (less taxing on my PC) and moving it along with its origin to the World Origin most of the shading (shadowing) issues just disappeared: enter image description here

Next some Vertex Smoothing to smooth out some of the sharper edges: enter image description here

And finally with the auto smooth option unchecked: enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you, it kind of works. The problem is that the smooth shading of the mesh is now off basically. $\endgroup$ – mikez Jan 18 at 18:36
  • $\begingroup$ So this is not a solution since flat shading is without this problem even with Custom Split Normals Data. $\endgroup$ – mikez Jan 18 at 19:22
  • $\begingroup$ This is so weird. But it finally works! Moving the object closer to the World Origin and scaling it down solves everything, so it was not a problem with *Normals in the end. I would really like to know why is this happening though. Maybe a bug? Anyway, thank you very much for this! $\endgroup$ – mikez Jan 19 at 5:31
1
$\begingroup$

This is a *Normals issue. Go to edit mode, select everything by pressing "A", and then select mesh. In the mesh menu, select normals then select re-calculate outside. If this does not work, then go to the vertex group tab in the properties tab, and check the box that says Normals auto smooth. Then set this value to about 25 degrees. Here's a picture:

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Not a solution unfortunately. There is a newly attached .blend file. $\endgroup$ – mikez Jan 18 at 3:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.