1
$\begingroup$

I am running Debian testing/unstable with LXDE as Desktop, and with the latest Blender update (2.71+dfsg1-1) selected vertices are drawn differently. See the following picture for a before/after view.left: before, right: after. How can I make selections again appear like in the left part of the image (except downgrading to a really old version)? Or is that a bug with the Debian version of Blender?

UPDATE: I installed the latest Blender for Linux from blender.org, blender-2.72-linux-glibc211-i686.tar.bz2 -- the problem is present in this version as well. This makes me wonder if it could be a problem with the Linux desktop. Are there graphics settings that can be tweaked?

Additionally, if I enable the setting 'Show Weights', the vertex is rendered correctly (left image), just everything has a blue tint. If I enable Shading -> Multitexture -> Matcap the selection is rendered correctly as well. This leaves me to believe it is not a bug related to the graphics drivers but to some other (default) setting that has changed recently. Any ideas?

UPDATE 2: I checked all combinations of options and with some the rendering is ok, with some not. With some it depends on the selection mode -- for example, with matcap if I switch to face selection mode, the middle point is missing. The bad thing is that there is no combination where the behaviour is acceptable :/

Probably not important, but with Windows 7 it works flawlessly (so I figure it's not a HW bug at least).

Hardware: Intel i7 860, ATI 5750 (I know, this one is ancient). I'm using default Debian graphics drivers which should be the open source ones. I should stress that until and including 2.69 there were no problems; the fact that I can switch on `Show Weights' and the lines are drawn correctly leaves me to assume that the drivers shouldn't be a problem. Is there more information I can provide?

$\endgroup$

closed as off-topic by gandalf3, David, PGmath, Polosson, Ray Mairlot Oct 7 '14 at 9:42

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question appears to be off-topic because it is a bug report and not an actual question. These should be reported to Blender's tracker instead." – gandalf3, David, PGmath, Polosson, Ray Mairlot
If this question can be reworded to fit the rules in the help center, please edit the question.

  • $\begingroup$ Would you provide the .blend file on the right? $\endgroup$ – Leon Cheung Oct 4 '14 at 0:32
  • $\begingroup$ You could try a different build from here: http://www.blender.org/download/ $\endgroup$ – user2859 Oct 4 '14 at 19:21
  • $\begingroup$ @LeonCheung: Not sure how to provide the '.blend' file, but I can reproduce the problem just by starting up Blender, creating a cube, use subdivision and voila (that's how I created the example images). $\endgroup$ – hochl Oct 5 '14 at 16:51
  • $\begingroup$ Make sure your graphics drivers are up to date $\endgroup$ – Greg Zaal Oct 5 '14 at 17:07
  • $\begingroup$ @GregZaal: I updated my question. $\endgroup$ – hochl Oct 5 '14 at 17:11
2
$\begingroup$

When a selection looks like that it usually means that there is a double vertex there. Two vertices in the same spot, and you only selected one of them.

To select both vertices, change the Viewport Shading mode to Wireframe Z, then with either circle select C, border select B, or just right clicking twice, select both vertices. If you want only one vertex there, with both (or more) selected press Alt M > At Center.

$\endgroup$
  • $\begingroup$ I can't reproduce this without using duplicate edges which are separate from the rest of the model, and edge select and vertex select enabled simultaneously. In other words, IMO this would be pretty hard to do once by accident, let alone consistently.. $\endgroup$ – gandalf3 Oct 5 '14 at 1:59
  • $\begingroup$ I am certain that there are no double vertices, but I have just confirmed it just to be 105% sure :^) See my comment on the main post. $\endgroup$ – hochl Oct 5 '14 at 16:49
  • 1
    $\begingroup$ But double Vertices will not have both tips of the edge colored, as OP's image on the right shows. $\endgroup$ – Leon Cheung Oct 6 '14 at 1:45
  • $\begingroup$ Could it be a multi-type selection issue while it looks like you get a vertex selected on the left image and on the right one two edges more. $\endgroup$ – Kriss Aug 5 '15 at 14:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.