1
$\begingroup$

I have this scene with a hand and a knife and I want to get an animation of blood sorta dripping (spraying) from it, but because of SSS I use in palm material it takes forever to render (over 4 minutes!), so I decided to render this image and use it as a background to free calculating space.

subsurface takes it forever to render!

I managed to shorten the time of frame render to 25 secs by using the pre-rendered image of a hand and knife as background image and translucent render of current frame mixed by the alpha mixer.

Nodles

It looked great and it worked just fine. But then I thought I can render only the region where the animation of blood flushing will be (marked it with red rectangle), so I turned on Render Region

Knife

Cycles cropped the background image in final render, though in the compositing viewer I see it how I thought it would look: whole and not cropped like this!

Could you kindly explain me what the heck am I doing wrong, is it a bug?

$\endgroup$
  • 1
    $\begingroup$ Are you trying to disable the cropping region ? The shortcut is CTRL + ALT + B $\endgroup$ – Gorgious Jan 16 at 21:49
  • $\begingroup$ No, i am trying to render a region and then merge this region with the background image using alpha over. $\endgroup$ – poumalchan Jan 17 at 5:52
0
$\begingroup$

I had the same problem. I decided to render only one layer and only "render region" without checking "crop the render region" (output menu -> dimensions) to png so the output is transparent.

After rendering separate frames of animation I put it together with alpha over node in the compositor. I wonder if there is a better way.

| improve this answer | |
$\endgroup$
  • $\begingroup$ @RayMairlot, fair enough, thanks for the heads up. It was actually in the original post so I didn't know if I could remove it or not. Now I know ! cheers $\endgroup$ – Gorgious Jan 23 at 19:00
  • $\begingroup$ @Gorgious Ah that's my mistake, I didn't see that it was in the original. $\endgroup$ – Ray Mairlot Jan 23 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.