0
$\begingroup$

I have a peculiar problem, which has been unfortunately recurring. I create a special material in nodes so I can see both textures and blend it with vertex colors. But this sometimes bugs (or maybe I set something wrong) and I have no idea how to fix it. On the picture you can see the material being applied to the object. The body of the washing machine, the door, the drum and all the buttons including the logo are all separate objects. I applied the same material on all of them, however only on the body it works at it should showing the colors. The other are black even though the UVs are set right and they all should appear as colorful as the body. When I switch to solid mode it looks as it should but under the material preview mode it turns black. This really puzzle me since there is nothing different in the setting, it is the same material, yet on the other parts it appears black and remains so even after restarting Blender.enter image description here

enter image description here

$\endgroup$
2
  • $\begingroup$ Did you correctly set the vertex color to something non-white on the black objects ? $\endgroup$
    – Gorgious
    Commented Jan 16, 2020 at 22:10
  • $\begingroup$ Hmm, not really but I found a solution. When I select the black parts and switch into vertex mode, it fixes it. Weird fix, but it works. $\endgroup$ Commented Jan 20, 2020 at 11:29

1 Answer 1

0
$\begingroup$

When I select the black parts and switch into vertex mode, it fixes it. Weird fix, but it works.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .