2
$\begingroup$

Started using blender, FPS was great, but the UI was flickering. Googled, I didn't have an opengl32.dll in the directory, then added it. UI Flickering gone, but FPS dropped drastically.

Would like some help on optimizing the FPS. I would rather work with the flicker and higher FPS but that's going to destroy my eyes in the long run.

CPU: i7-6700k 4.0 up to 4.4 ghz

GPU: MSI VENTUS OC RTX 2060 Super

RAM: DDR4-3600 32gb 2x16

$\endgroup$
2
$\begingroup$

Here's a trick that will let you see a faster frame rate while sacrificing a few frames here and there while cycling through the animation: Use frame dropping playback. What this does is remove a few frames here and there while playing the animation so that the playback speed looks normal. Don't worry! This does not affect the playback of the final render. Here's a picture:enter image description here FYI this is 2.79. If you use 2.8+, the playback type is next to it.

$\endgroup$
2
$\begingroup$

For anyone who still wants an answer to this, here's how you can increase FPS playback in viewport (Some of these I didn't find anywhere else) (These work in Blender 2.79. Plz let me know if these work in new Blender(s)!).

Gaining the Most FPS

  • Put armature modifier above Subdivision Surface and Solidify Modifiers. (But keep it below mirror modifier or else mesh may split in half).

  • P.S. did you know, applying a subdivision modifier slows down FPS a lot? (Except in BGE game engine). So, if you're not already using a subsurf modifier, consider making the mesh again as a low-poly with a subsurf modifier.

  • Turn off Quad View (only works if Armature modifier is above Subsurf modifier)

  • Use Solid Viewport if you aren't already.

  • Use Mask Modifier to hide vertices such as skin that's underneath clothes or hair. (Make sure it's above subdivision surface modifier. And click the <--> button.).

  • Try a lightweight Ubuntu OS. You can try the OS before installing. Both Bodhi Linux (with app pack) and Zorin OS (Lite Education Edition) play fps much faster than on Windows 10. Ubuntu distroses aren't always user friendly tho, in my experience.

  • Use Simplify (this lowers subsurf for every object).

  • Or lower subsurf for each object (you can start with less important objects if you still want high detail).

  • ??? Bake textures or physics cloth simulations? I don't use these so I can't say much here.

Gain Little Bits of FPS Here and There

  • Use only one 3D Viewport (press Shift+Spacebar)

  • Hide Bones (Tip: put bones on a separate layer. This makes it convenient to hide and show bones really quick. You can use alt+1 or alt + any other number if you're already using other layers.)

  • Put any solidify modifiers at the very bottom?

  • Don't move your mouse. I lose 1-2 fps that way, lol.

  • Turn off OpenGL Lamps (for Solid Viewport) (+1 to 2 FPS) Not sure if this is in new blender. Top of the Screen > File > User Preferences. System tab. Right hand side: Under Solid OpenGL Lights: Turn off the 3rd lamp (and 2nd lamp if you really want to, but everything will be dark)

  • Tip: Set selection to OpenGL Occlusion Queries. This will fix lag whenever selecting bones.

  • Supposedly, turning on ‘show only render’, or hiding selection outlines relationship lines, etc. helps. I don't notice a difference, tho.

  • Matcaps seem to not slow down FPS. Texture looks nice, but all objects must have the same texture at one time (afaik).

___These settings are usually set properly by default. But Just In case you accidentally changed them... ___ Window Draw Method (1st part) should NOT be Full. Or else Fps will drop a lot!

Region Overlap should be unchecked.

And yeah, Frame dropping is also a useful tip.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.