2
$\begingroup$

I have tried multiple times to export a simple design made from importing an svg file, extruding and adding textures to gltf, glb etc and it seems that there is just no way for blender to export the file. It works with a simple cube, so I believe I must have selected a wrong parameter that stops the models from being added to the file.

So I select my two objects I want to be exported:

enter image description here

Exporting them in separated form,

enter image description here

The export doesn't contain the models:

{
"asset" : {
    "generator" : "Khronos glTF Blender I/O v1.0.5",
    "version" : "2.0"
},
"scene" : 0,
"scenes" : [
    {
        "name" : "Scene",
        "nodes" : [
            1
        ]
    }
],
"nodes" : [
    {
        "name" : "path28",
        "translation" : [
            0.01957155205309391,
            0,
            -0.06752680242061615
        ]
    },
    {
        "children" : [
            0
        ],
        "name" : "path24",
        "rotation" : [
            0,
            0.258819043636322,
            0,
            0.9659258127212524
        ],
        "scale" : [
            2.5,
            1,
            2.5
        ],
        "translation" : [
            0,
            0,
            0.045051999390125275
        ]
    }
]

}

I have general suspicion that it has to do with my models textures, but I have very little experience with blender, so it could be that a simple material / object selector was turned off?

Thanks for any indication

$\endgroup$
2
$\begingroup$

glTF is a GPU-ready format that only supports meshes, not other types of geometry directly. Your SVG has imported as curves, not meshes. To make it compatible with glTF, look for the convert option in the Object menu of the 3D view:

Object -> Convert To... -> Mesh from Curve/Meta/Surf/Text

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.