2
$\begingroup$

EDIT 2: Thanks to a user posting a detailed technical explanation as to why the bug is manifesting (TL:DR, certain material properties cause multiple calls to the shader compiler in the AMD driver when only a single one is necessary), I have found a couple of workarounds:

  • Set the blend mode to alpha blend (This affects the output)
  • Enable backface culling on the material (This usually doesn't affect the output unless you care about how the inside of your mesh appears)

More details on Backface Culling here

Issue in the bug tracker here


EDIT: As stated below, the sword in the tutorial files exhibits the same behaviour, but I've also provided a blend file for the sword I built whilst following the instructions in the tutorial.


I've been following this tutorial series as part of my efforts to learn Blender.

Things were going okay, until I got to the shader part of the tutorial, more specifically the part where I'm supposed to add a material to the grip of the sword, which has a different base colour and the metallic setting turned down to 0. As soon as I turn the metallic value down, performance falls off a cliff and the frame rate in the editor drops to single digits. Blender is basically unusable.

If I leave the metallic slider on 1, then performance is fine.

I used Bootcamp to import the same blend file into the Windows version of Blender on the same machine, and the performance is fine regardless of what metallic setting I apply to the sword handle. This suggests it must be either:

  • An issue in OSX Catalina
  • An issue in the OSX OpenGL implementation
  • An issue in the OSX version of Blender

Has anybody else ran into this issue and found a way of addressing it? The hardware I'm running is definitely capable of doing the job.

The system specs are:

  • 2019 Macbook Pro, 16 inch
  • CPU: Intel i9, 8 cores, base clock 2.3 GHz
  • GPU: AMD Radeon Pro 5500M, 8 GB
    • Secondary GPU (not in use for this scenario): Intel UHD Graphics 630 1536 MB
  • RAM: 64 GB
  • OSX Catalina, 10.15.2
  • Blender 2.81a

Only other application running is a browser so I can follow along with the tutorial video.

I have downloaded the tutorial files from the website linked in the video, which includes a finished version of the sword, and I have confirmed that the behaviour in the model provided in that bundle is exactly the same. If I load it as is the performance falls off a cliff, but if I bump the slider for metallic up to 1 performance returns to normal. This means that I've not doing anything wrong (as far as I know) while modelling my own sword and it should behave like the one the tutorial maker built.

$\endgroup$
  • $\begingroup$ Can you share the file? blend-exchange.giantcowfilms.com $\endgroup$ – Jackdaw Jan 12 at 16:09
  • $\begingroup$ @Jackdaw As mentioned in the question, the sword bundled in the tutorial file exhibits the same behaviour. But I'll upload my version there too shortly if it'll do any good. $\endgroup$ – GordonM Jan 12 at 16:51
  • 1
    $\begingroup$ This is a reported bug: developer.blender.org/T66231 $\endgroup$ – Jackdaw Jan 12 at 17:10
  • $\begingroup$ @Jackdaw I guess that's the answer! If you can also provide a workaround in an answer I think I can promise it'll get accepted. I tried messing with setting metallic to various values and the behaviour seems to happen if you set it to any value other than 1. Was hoping I could just set it to 0.001 for now or something. $\endgroup$ – GordonM Jan 12 at 18:11
3
$\begingroup$

This is a reported bug: https://developer.blender.org/T66231

I can't think of any way other than downgrading to a previous version without this issue :-P

| improve this answer | |
$\endgroup$
  • $\begingroup$ I can hide the handle when not working on it. That'll do for this particular case because it's the only non-metallic thing in the whole object, but obviously long-term that's not going to be practical. $\endgroup$ – GordonM Jan 12 at 18:46
  • 1
    $\begingroup$ Found a better workaround. See updates to the original question. $\endgroup$ – GordonM Jan 12 at 22:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.