0
$\begingroup$

I can hide the emitter easily and control the end where the particles "die out".

Yet I'm also looking for a way to hide the initial portion of particles lumped up i front of the cue of a system with a path force field.

Yet I need a procedure to control/hide the initial particles on the curve like you can hide the "unborns".

Please keep in mind I'm going for the "non-curve-guide" method since I learned this will produce the best result.

Kind regards, Mikael

enter image description here

$\endgroup$
  • $\begingroup$ Cycles or Eevee? For Cycles use Particle info's age/lifetime ratio to mix shader with Holdout to mask those parts. Or use texture coordinates to holdout anything below world origin, assuming only cube is below it (judging by pic). $\endgroup$ – Serge L Jan 10 at 9:03
  • $\begingroup$ Thanks, very nice advice concerning cycles:-), yet it is eevee I'm focused on. $\endgroup$ – Mikael Jan 10 at 13:37
  • $\begingroup$ Well, try then object texture coordinates to limit visibility of particles on Z axis. This should work for both render engines $\endgroup$ – Serge L Jan 10 at 13:41
  • $\begingroup$ Uh, I must admit that I'm not very familiar with what you are suggesting. Is this the node panels in question? ibb.co/CsndvVr $\endgroup$ – Mikael Jan 10 at 13:58
  • $\begingroup$ Nothing moves in my file because physics are switched off. Emitter provides coordinates and Mapping node's parameters adjusts shape of spherical texture. You can just append material into your existing file and play with Mapping node settings and Value of Greater Than to put emitter cube inside this sphere mask, but keep curve-guided particles out of it as much as possible. $\endgroup$ – Serge L Jan 12 at 9:27
0
$\begingroup$

Texture mask to hide unwanted particles in center (red outline) but keep surrounding visible (green outline).

Emitter object's coordinates controls spherical texture which gradient splits material in two shaders: default and invisible (holdout or transparent BSDF for your choice).

Holdout is easier for render but needs compositing, while transparent with many overlayed particles need many transparency bounces to get clean results.

enter image description here

| improve this answer | |
$\endgroup$
0
$\begingroup$

Thanks alot for your linked blend-file with masked areas and kind info!

Yet feeling totally noob-terrible for my part: Nothing moves when playing the timeline. And beyond frame 50 the particles disappears. This is what I see: https://drive.google.com/open?id=1VoTgBOUeZktjg0so7vsfSlID3J5n0_wF

I'm sorry to say I can't comprehend what is going on and do not grasp the concept (ie. “... controls spherical texture”). I've long ago learned about Texture Space (yet cannot get the yellow box with dotted line meaningfully to switch on in the file). Is this related to your setup?

Trying to “deconstruct” the file also leaves me puzzled. The object named “Cube” to make it behave as a normal one I can’t ”reset” (==deleting the material attempting to make it visible, adding new materials etc. just to figure out the nature of it) Even the use of the 1-29 linked collections I don’t understand.

It’s a bit up hill (to me;-)) for the moment as you might see but could you give me a cloue of the idea behind?

I Guess I must have to learn more about the Blender texture space concepts you use before I understand your explanation/file. Would very much like if you have links or perhaps some words to search for. With gratitude for your helpfulness!

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.