1
$\begingroup$

Using Cycles in Material Preview mode and planes that intersect each other display oddly - one plane displays fully and ignores the fact part of the other plane should be showing. Better explained in the image below.

planes crossing in Material Preview

How do I get them to act how they do in Solid view where they appear how I would expect them to: planes crossing in solid view

Couldn't find an existing question for this, expect it's something obvious I'm missing.

$\endgroup$
2
$\begingroup$

This looks like an "alpha clipping" issue.

Your planes look like they have an image texture applied to them. If this is correct and the image has an alpha channel (for transparency) then try setting the Material Properties > Viewport Display > Blend mode to Opaque.

Example Plane textured with an Image with an Alpha channel: enter image description here

enter image description here

Or even better Open the image in Gimp or Photoshop and remove the Alpha Channel ( Gimp : Layer > Transparency > Remove Alpha Channel

Edit to add a couple more screenshots after Hienronymous's comment.

The Show Backface option is not available when Blend Mode is set to Opaque but there when Blend Mode is set to the default Alpha Blend Which (probably) makes sense since the two seem to preform similar functions.

The Blend Mode Opaque "Renders surface without transparency" and with Show Backface deselected "avoids transparency sorting problems".

enter image description here

enter image description here

$\endgroup$
1
$\begingroup$

Typically found the answer after an hour of fiddling.

Under the Materials tab scroll down to Settings and uncheck "Show Backface".

enter image description here

$\endgroup$
3
  • $\begingroup$ In Blender 2.81 I don't see the Material tab > Settings > "Show Backface" option. Do you mean "Backface Culling" ? Didn't look like a Backface Culling issue. Typically with Backface Culling enabled the back face becomes completely invisible which is not the case in your first image. Just curious and Welcome to the Blender Stack Exchange forums :) $\endgroup$ – 3fingeredfrog Jan 8 '20 at 18:05
  • $\begingroup$ Thanks for the warm welcome! It seems "Show Backface" doesn't appear by default on most materials, but when Importing Images as planes the option shows in the material settings. $\endgroup$ – Hieronymous Jan 9 '20 at 17:38
  • $\begingroup$ Thanks, We learn a little more every day :). I edited my answer to try to illustrate your comment. $\endgroup$ – 3fingeredfrog Jan 9 '20 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.