1
$\begingroup$

I want to loop keyframes in Blenders Curve Editor. But I can't find a way to do this.

If I select the curve / keys I want to loop and right click and select the animated channel and select "extrapolation method" - they are greyed out and I can't change anything.

It seems like it tries to tell me to use "F-Modifiers" - but I can't find them in the interface ("shift-E" doesn't work as I am using industry standard keys).

A short search in the Blender documentation only reveals screenshots of an older interface version and I can't find the "F-Mod" / "Modifiers" Buttons in the 2.8(1) Version. (https://docs.blender.org/manual/en/latest/editors/graph_editor/fcurves/modifiers.html)

Do you know where I have to click or a tutorial that explains it?

$\endgroup$
1
$\begingroup$

The panel is hidden behind this tiny arrow:

enter image description here

This expands it and you can select the Modifiers tab (Cycles is the one you want)

enter image description here

The standard shortcut is "n", but I don't know about the industry compatible keymap.

$\endgroup$
2
  • $\begingroup$ Ah! Thank you so much. It's so tiny! $\endgroup$
    – user86555
    Jan 7 '20 at 12:31
  • $\begingroup$ Sure thing! Be sure to mark the question as answered, so others looking for the same thing know where to search :) $\endgroup$
    – tobkum
    Jan 7 '20 at 12:55
1
$\begingroup$

Besides the real settings which I was looking for pointed out by "tobkum" I also found another way to change the greyed out setting:

Selecting the layer / keys then clicking on "Channel" in the Curve-Editor Menu and then Selecting "Extrapolation Mode" also let's me set the modes. But you'd still need the menu pointed out by tobkum for further settings.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.