0
$\begingroup$

I'm currently trying to take a 3D model and reduce the amount of faces/verts/tris it has, since it has quite a lot currently (over 100k tris). It seems that any method I choose causes the model to break when exported to FBX and imported into Unity.

  • As the model is by default, before reducing vertices, I can export it to FBX and then the model works fine in Unity.

  • If I use "Merge by Distance" or "Limited Dissolve" or any other "Clean Up" modes, when exported the model simply disappears and Unity spams these two errors:

Assertion failed: Invalid AABB *this UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)
Assertion failed: Invalid AABB a

I really have no idea what would cause this, I'm a beginner in Blender. Is there any way to check if the model has issues in Blender before exporting? Or maybe it's an issue with exporting?

Alternatively, it would be fine to keep the high amount of vertices in the blend file as long as I can reduce it on export. Is there any kind of surface modifier I can apply to reduce vertices?

$\endgroup$
  • $\begingroup$ Have you tried decimate modifier? If the topology isnt a main thing for you I use the decimate. $\endgroup$ – Fowl Jan 7 at 8:40
  • $\begingroup$ Hmm... "Decimate Geometry" works, but only if I enable Symmetry over the X axis (which happens to work fine for my use case). If I have symmetry disabled, the model is displayed (so not the same problem), but the UVs are messed up and part of the model turns white. $\endgroup$ – Aaron Franke Jan 7 at 19:40
  • $\begingroup$ yeah the UV will be problem, it pretty much destroys the topology $\endgroup$ – Fowl Jan 8 at 8:02
  • $\begingroup$ I'm assuming the UV's still work in Blender- I don't use Unity but did have a similar answer for someone on the BA forum. As in I find the Decimate modifies keeps the UV's just fine- blenderartists.org/t/custom-build-blender-fracture-modifier/… $\endgroup$ – MarkS Jan 8 at 9:51
0
$\begingroup$

I figured out what was wrong in my particular case. Reducing the amount of vertices completely breaks the model if the model has shape keys. It's really annoying that Blender doesn't give you a warning about this, but basically, the solution is that you have to delete any existing shape keys before decimating or performing similar operations.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.