1
$\begingroup$

I have two objects (from a Collada import), one can be beveled, the other not. I cannot see any differences in the mesh. I checked for non-manifold edges, I checked for the orientation of the normals, I checked for sharp edges, ... What am I missing?

Blender screenshot

The .blend file (version 2.81) can be downloaded here: https://www.dropbox.com/transfer/AAAAAP6OKinOxeC5PAGGCIZJp6WsqX2sHdYds-C1aVJGl63GLkFIH_g

Thanks in advance for any help!

Chris

$\endgroup$
2
$\begingroup$

There are many duplicate vertices.

In edit mode, select all (A), then Right click > Merge > By distance.

| improve this answer | |
$\endgroup$
  • $\begingroup$ That's it! And it was quick! Why does the "problematic" mesh now looks nicer than the other one? $\endgroup$ – Chris S. Jan 6 at 13:11
  • $\begingroup$ First, one has some faces set as smooth. To even things off, do Object > Shade smooth on both objects. They will still look different, though, because for some reason the vertex normals are at 90 degrees with the "other" and at 45 degrees with the "problematic" $\endgroup$ – Nicola Sap Jan 6 at 13:21
  • $\begingroup$ Using "Harden normals" in the bevel modifier options of the "Other" one, in addition to "Shade smooth" on both as stated above, will make them look the same. $\endgroup$ – Nicola Sap Jan 6 at 13:23
  • 1
    $\begingroup$ @ChrisS. Please don't add thank you as an answer, upvote the answer instead. If you feel it completely solved your problem consider marking it accepted $\endgroup$ – Duarte Farrajota Ramos Jan 6 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.