17
$\begingroup$

When using Eevee, an object with a glass material (in this case: Principled BSDF, trasmission set to 1.0) doesn't seem like it can be looked through: it's completely opaque.

See for instance the material for the blue cube in this scene:

enter image description here

How can I get my glass material to be transparent?

$\endgroup$

1 Answer 1

19
$\begingroup$

By default, some options that require extra computing efforts are turned off in Eevee and they must be turned on manually.

In the case of a refractive object, you must enable:

  • Under the Render settings, Screen Space Reflections and, within it, Refraction. manual.

    enter image description here

  • Then, in each of your refractive materials' Material settings, you should enable Screen Space Refraction. manual.

    enter image description here

If your material has some kind of Alpha transparency (e.g. a Transparent BSDF shader), you should also select a suitable Blend Mode. manual.

$\endgroup$
2
  • 1
    $\begingroup$ Great Q&A. Can't even remember how many people I referred to it :). $\endgroup$ Commented Oct 3, 2020 at 13:37
  • $\begingroup$ Fun fact: these options have already changed spots in Blender 3.1.2. Screen Space Refraction, for example, is under Viewport Display > Settings. "Screen Space Reflections" however is nowhere to be found in the Sampling tab or when I search for it. Back to Blender 2.7 I go once more... what a nightmare $\endgroup$ Commented Dec 9, 2022 at 21:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .