3
$\begingroup$

So this may be a noob question, but I've got a video set up with nodes, and I go to render, but blender makes 2 passes, one is the scene (which had been previously used for smoke simulation but doesn't have anything in it now) and then the compositor. It slows it down a lot, and I can't find anything online about how to only render one part of the blender project, wether it be the 3D scene, the node compositor, or the VSE. Help please?

$\endgroup$
6
$\begingroup$

Delete the renderlayer node from the node setup, and then blender won't render the 3D scene.

If there is anything in the VSE or the compositor, by default blender will prioritize rendering it over rendering the scene unless you explicitly disable it in the render settings:

enter image description here

If use nodes is enabled, then blender will only render the 3D if it's needed for the composite. (i.e. there is a renderlayer node using the scene as input)

$\endgroup$
  • $\begingroup$ the scene that has the nodes? or the 3D scene? $\endgroup$ – DragonHeart Sep 29 '14 at 23:01
1
$\begingroup$

I usually attach a Viewer Node into the node setup. Then in the UV/Image Editor, open the Viewer Node and then save the file using F3.

$\endgroup$
  • $\begingroup$ Please consider adding some screenshots to your answer. $\endgroup$ – user7952 Jun 17 '15 at 3:19
  • $\begingroup$ Please add more to your answer. $\endgroup$ – David Jun 17 '15 at 3:34
  • $\begingroup$ Thats great, for pictures, but its an animation. $\endgroup$ – DragonHeart Jun 18 '15 at 16:12
0
$\begingroup$

Create a new render layer and uncheck the old one. In this layer, unselect everything.

Layers Tab Render Tab

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.