0
$\begingroup$

I want to use vertex colors as a mix factor in my material. However when I chose Add->Input the option Vertex Colors doesn't show up. Why can I not access the vertex colors data? I want to avoid using any python scripts or any workarounds with the Attribute node if possible. Using Blender 2.8.

enter image description here

$\endgroup$
  • $\begingroup$ @Robert Gützkow I actually read that thread beforehand, but I feel like there should be a more intuitive way. $\endgroup$ – Felix Keßler Jan 4 at 14:55
  • $\begingroup$ @Frederik Steinmetz thanks for the suggestion, I will probably use the addon. Sometimes I'm getting very sick of blender. I'm kind of a minimalistic person wanting to do minimalistic things and I can't wrap my head around why this seems to be a problem and needs some (third party?) addon. $\endgroup$ – Felix Keßler Jan 4 at 14:58
  • $\begingroup$ 2.81 has that node finally $\endgroup$ – HenrikD Jan 4 at 15:34
  • $\begingroup$ @HenrikD oh really? perfect, downloading it right now! $\endgroup$ – Felix Keßler Jan 4 at 15:42
0
$\begingroup$

Even easier than the suggestiong of @Robert Gützkopf: Enable the Node Wrangler Addon. It will put that option exactly where you pointed out it's missing.

| improve this answer | |
$\endgroup$
0
$\begingroup$

As it turns out, Blender version 2.81 has this exact same feature natively built in. For older versions, you can enable the Node Wrangler addon for a similar feature, or you have to use the Attribute node (which for me is not the most elegant solution but works just fine). Thank you everyone for your help!

| improve this answer | |
$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.