0
$\begingroup$

I am trying to model a simple room to make my sword model easier to understand (I was getting confused because the reflective material had nothing to reflect), but I cannot figure out how to make my wall material the right colour. I want the walls to be a bright yellow with small bumps on it. I attached a bump map and a normal map to the material. My trouble seems to be with the "emission" value in the "PrincipledBDSM" shader. I cannot get my bright yellow because of it. With the material colour set to yellow and emission set to black, I get a dark yellow. If I change the emission to yellow, I still get a dark yellow. I thought maybe I could change the alpha value of the emission but it seems to ignore the alpha channel. How do I get the object to follow a bump or normal map and let me chose the colour?

here is the file: https://we.tl/t-46j7Osx6aD

$\endgroup$
8
  • $\begingroup$ maybe just put lights in the room and dont use transmission or emission... $\endgroup$
    – HenrikD
    Jan 4, 2020 at 9:16
  • 1
    $\begingroup$ I think you meant to write Principled BSDF (Bidirectional Scattering Distribution Function), the abbreviation you've used means something totally different. $\endgroup$
    – Robert Gützkow
    Jan 4, 2020 at 9:50
  • $\begingroup$ If the emission is set to black on the Principled BSDF then it won't emit any light. Since you're walls aren't supposed to emit light on their own (I assume), you will need to add additional light sources to illuminate the scene. If you don't want to model the surroundings and simply showcase your model, you could also use an HDRI to light the scene. $\endgroup$
    – Robert Gützkow
    Jan 4, 2020 at 10:34
  • $\begingroup$ @RobertGützkow omg you're right! LOL! $\endgroup$ Jan 4, 2020 at 15:27
  • 1
    $\begingroup$ @LightOfTheNight try increasing the strength of the emission shader of the lamps until it is bright enough $\endgroup$
    – HenrikD
    Jan 4, 2020 at 15:30

1 Answer 1

2
$\begingroup$

try setting the transmission on 0, and emission black

$\endgroup$
5
  • $\begingroup$ the image of the normal map is not attached so I cant see how the bump works: it should work tho, the transmission on 1 is changing the color $\endgroup$ Jan 4, 2020 at 7:53
  • $\begingroup$ This seems to have worked! Although I could have sworn that I tried it before. Can you explain why transmission controls emissions? $\endgroup$ Jan 4, 2020 at 15:29
  • $\begingroup$ @LightOfTheNight it controls how much light it transmitted. If your walls are transparent, you will see what is behind them, not the light scattering from the inside $\endgroup$
    – HenrikD
    Jan 4, 2020 at 15:32
  • $\begingroup$ that makes sense, thank you @HenrikD $\endgroup$ Jan 4, 2020 at 19:28
  • $\begingroup$ could it be that I am hiding the texture somehow? $\endgroup$ Jan 5, 2020 at 4:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .