0
$\begingroup$

So, after finishing the modeling process, I select all with A, then I solidify in order to 3d print the model, getting those weird results.

Edit: Part of my file, where the problem is present

How it looks before solidify: enter image description here

How it looks after: enter image description here

How do I solve this?

Edit: I triangulated everything, same result. Looks like some sections are not affected by solidify, also some holes. I spent like 100 hours to model this, hope I can fix it.

Some parts won't solidify

enter image description here

$\endgroup$
  • $\begingroup$ Have you tried using the Even Thickness option? $\endgroup$ – stphnl329 Jan 2 at 21:29
  • $\begingroup$ Yes, didn't help $\endgroup$ – Lahey Corey Jan 2 at 21:40
  • 1
    $\begingroup$ Hello :). To prevent further guessing, you can share your .blend file, so others can take a look. $\endgroup$ – Jachym Michal Jan 2 at 22:34
  • $\begingroup$ .blend uploaded $\endgroup$ – Lahey Corey Jan 3 at 11:17
2
$\begingroup$

1: (Not necessary but to simplify things) remove the Mirror and Solidify modifier.

2: Open the Viewport Shading menu and enable Backface Culling.

enter image description here

Now the problem is revealed. Mesh faces only have one side, With backface culling enabled we can see this. Your models has half the faces facing outwards (which is good) and the other half facing inwards (which is not good). To correct this

3: In Edit mode select all of the mesh and open the Mesh menu, Mesh > Normals > Recalculate Outside.

enter image description here

4: Look carefully where the face is selected in the screenshot below and you will see a face that should not be there. Delete this face and fill in the gap it leaves. enter image description here

5: Now you can add back the modifiers enter image description here

Looks ok now :) ................

........... apart from the weird edge flow ! As with most things but especially cars, edge flow is very important. I suggest you find a car modeling tutorial on Youtube and pay special attention to that. Takes time, sometimes you will spend hours and hours just tweaking existing vertices until it is ............ just right.

Edited to illustrate Nicola's suggestion in the comments enter image description here

Edited to reply to comment: Often its extrude in one direction and the face normals are ok, extrude in the opposite direction and you find the face normals are now reversed.Work with backface culling enabled and you will notice problems and can fix them as you go along.

Advice on edge flow? Spend a few hours watching car modeling tutorials on You tube. Avoid Ngons and tris where possible and most important of all keep it as low poly as possible. The more geometry you have the harder it is to tweak.

Try for something similar to the screenshot below.

Note this is only the side of the car. If I was intending to model the complete car, at the same time as adding the circles for the wheel arches I would also have added a circle for the front radiator grill and work back from there.

enter image description here

enter image description here

For this Youtube is going to be your best friend. Good luck.

| improve this answer | |
$\endgroup$
  • $\begingroup$ A face like the one highlighted in (4) can be probably found by using F3 > Select Non Manifold $\endgroup$ – Nicola Sap Jan 3 at 14:35
  • $\begingroup$ Thanks! So there was the problem, I don't know how I ended up with faces facing opposite directions. What I been doing all the time is basically extruding faces and positioning the vertices according to the reference images all the time. Sometimes I created faces from vertices. 3fingeredfrog, any suggestions for better edge flow? I tried to use 4 vertices faces, because if not I won't be able to use loop cuts if required, but for some parts triangles where more convenient, or ngons made the work easier, and since I was not going to work again on those places, it was ok. $\endgroup$ – Lahey Corey Jan 4 at 11:29
1
$\begingroup$

This can only mean one thing, your topology has gone bad. Many of the modifiers such as subsurface will not work properly if you have overlapping faces. There could also be other issues. Check this forum for more issues to look for. Very odd geometry when using solidify modifier

| improve this answer | |
$\endgroup$
  • $\begingroup$ Well, I used some ngons. Could it be beause of that? $\endgroup$ – Lahey Corey Jan 2 at 21:48
  • $\begingroup$ Yes, it could Ngons are risky business. You should try a subdivision surface modifier and if that does not work like it should and you find points and creases in it, it could point to where the mess is at if you cannot find it with the solidify modifier. $\endgroup$ – TheMuffinMan Jan 2 at 21:53
  • 1
    $\begingroup$ Some thoughts.... 1. Have you applied all transforms? Object mode, Object > Apply > All Transforms. 2. Are the normals ok? Edit mode, Mesh > Normals > Recalculate Outside. 3. have you checked for overlapping vertices? Vertex > Merge Vertices > By Distance. 4.Mesh > Clean Up > Degenerate Dissolve. 5. Solidify Modifier > Thickness set to a more realistic 0.003. If these didn't solve anything share your .blend (or even only a part of it ) so others can check it out for you. $\endgroup$ – 3fingeredfrog Jan 2 at 23:17
  • 1
    $\begingroup$ 0.003m = 3mm, :) (0.001m = 1mm) $\endgroup$ – 3fingeredfrog Jan 2 at 23:48
  • 1
    $\begingroup$ More thoughts, ....... Don't forget to set smooth shading. Mesh > Shading > Smooth Shading, and from the Properties viewport open the Object Data properties tab (the one that looks like a green triangle) go down to the Normals menu and check the Auto Smooth option. Also, perhaps need an Edge Split modifier. $\endgroup$ – 3fingeredfrog Jan 2 at 23:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.