2
$\begingroup$

I would like to render a plank with a notch, as shown below, in wire-frame mode.

It should only show the outer edges, means I would like to not show the edges highlighted with the white arrows.

Is there such an option?

Also, related, why are some edges thicker than others?

enter image description here

$\endgroup$
2
$\begingroup$

To hide the edges between faces that lay on the same plane, use a Decimate modifier above your Wireframe modifier.

Set it to Planar mode, and adjust the angle limit if needed.

enter image description here

The inconsistent line thickness is caused by the original mesh having been scaled up in the three dimensions with different scale factors. The mesh "remembers" these factors and applies them to the modifier results, making the wireframe stretched weirdly. To fix the problem, you must make the mesh "forget" that it has been stretched, and make the new scale permanent ("Apply" the transformation). To do so:

  • select the object
  • do Ctrl+A > Scale.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ How did you make the notch? I used 3 loop cuts and one grab of the center edge to move it inwards. However, I then have 144 faces and the "decimate" modifier does not work as it should (I need to crank the angle to 90 and then some faces appear again). $\endgroup$ – Felix Jan 2 at 20:32
  • 1
    $\begingroup$ A cube with 3 loop cuts (which is what also I did) is 18 faces, not 144! 144 is what the wireframe gets you, but note that the decimate modifier should go ABOVE the wireframe modifier! (See when I click the little up arrow in the gif) $\endgroup$ – Nicola Sap Jan 2 at 20:45
  • $\begingroup$ Got it, that was the trick! $\endgroup$ – Felix Jan 2 at 20:47
1
$\begingroup$

if the question is about Wireframe view, rather than Wireframe modifiers, this (older) answer may be relevant

There is an option to hide wireframe edges between faces that are at a small angle.

It's in the "Overlays options" menu of the 3D viewport, under Geometry > Wireframe:

enter image description here

I'm surprised as I would expect all the edges you've identified to disappear for values less than 1.0, yet two are remaining. I'm checking whether this should be considered a bug.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.