7
$\begingroup$

I'm having difficulties to understand what happens with textured models using alpha textures in Blender's viewport.

As exemple,I have a fence made of a grid (which is an alpha texture), or some trees with leaves, using as well obviously alpha textures. And all the time, I have edging around my models...

Unless I select my model ! Indeed if my model is selected, I don't see anymore these edgings around my leaves, grids and etc..

Why ? And how to solve it !?

example

$\endgroup$
  • $\begingroup$ At first glance this seems like an alpha problem. I tried quickly, but cannot reproduce your problem. Can you include a picture, that would be helpful. Also, which image format are you using? $\endgroup$ – jasperge Jul 4 '13 at 10:34
  • $\begingroup$ I put a link in my first post. It seems I have as well the prob when the mesh is selected, check the picture, you'll notice the big palmtree is the one selected, the problem is present as well even if it's selected finally... $\endgroup$ – Azuk Jul 4 '13 at 10:58
  • 1
    $\begingroup$ This looks like it might be an issue of having an image with premultiplied alpha and Blender is treating it as being non-premultiplied (straight) alpha. What image format are you using for your textures? $\endgroup$ – Fweeb Jul 4 '13 at 12:41
  • $\begingroup$ This post might help somewhat.. $\endgroup$ – iKlsR Jul 4 '13 at 14:48
  • 1
    $\begingroup$ As @Fweeb mentioned it's probably an issue with straight or premultiplied alpha. Try changing the alpha setting for your image(s) to premultiplied or straight (depending how it's set now) in the image settings. $\endgroup$ – jasperge Jul 4 '13 at 14:58
2
$\begingroup$

Well, finally, I I've found the way to "solve" it, if that could be called really an issue... It's true that Blender display badly meshes with alpha material if the map is low quality or small when I'm in the "Blender render" mode, well from what I've tested, that's what I've noticed...

However here, as I'm working with low poly assets and small maps, I just switched to "Blender Game engine" render, and by pressing "P" to have a preview of the "game", I don't have anymore those artefacts... There was as well the fact the shader was set in the shading tab to "shadeless" ! Unchecking this, is also important, even thought in this case I really want the shader to be shadeless...

Sorry for my ignorance... I guess you didn't think about that because that was too much simple...

$\endgroup$
1
$\begingroup$

Another relevant option is the Clip Alpha setting in User preferences > System:

enter image description here enter image description here

This makes all alpha below a certain amount completely transparent.

$\endgroup$
  • $\begingroup$ You are totally right about that, that's another setting to look at to solve the issue I had ! That's even the most important in fact... $\endgroup$ – Azuk Nov 16 '13 at 10:44
0
$\begingroup$

Try a higher level of png file (png 32 or higher). I believe that png 24 is not the best quality for Alpha. Check out this sight: http://blog.deepbluesky.com/blog/-/the-difference-between-png24-and-png32_49/http://blog.deepbluesky.com/blog/-/the-difference-between-png24-and-png32_49/

In my case (on a Mac), the png files don't appear to have a number attached. I tried 'Premultiplied' and 'Straight', and the 'Straight' definitely works better.

$\endgroup$
  • $\begingroup$ Awful. Premultiplied or straight alpha isn’t an option; figure out what type it is, and do the proper operation. $\endgroup$ – troy_s Dec 31 '18 at 5:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.