0
$\begingroup$

I had a Nvidia GT 1030 graphics card 2 Months Ago. Back at that time I followed a BlenderGuru tutorial to make a donut. I could render it perfectly. Let's just call that file Donut.blend

https://drive.google.com/open?id=1EcyqoXdAokoTObYmUztQa9PLKH__h3t6 Here You can get my test files including donut.blend (Note:- cube.blend at this link was created using 2.81a)

But then I switched to a Radeon RX580 which I can use to render with Radeon ProRender but only with newly created 2.81 Blender files.

I also collected the sample from this thread. The blend file attached https://community.amd.com/thread/240919 here also works, using 2.81a (current version). Even if the fact is that it was a 2.8 file.

But the donut that I made 5 months ago using blender 2.8, doesn't render using Radeon Pro Render.

  • CPU (i3-4150) + Cycles works fine for Donut.blend on both Blender 2.8 and 2.81a
  • RX580 Gpu + Cycles doesn't work for Donut.blend on whatever blender version I use. (Checked way back till 2.79.)
  • RX580 + Radeon Pro Render doesn't work for Donut.blend (tested on 2.81a, 2.81, 2.81 beta, 2.8, 2.8 beta)

(Donut.blend won't run on 2.79 as it was created using 2.8)

  • CPU + Radeon Pro Render doesn't work for Donut.blend (tested on 2.81a, 2.81, 2.81 beta, 2.8, 2.8 beta).
  • CPU + RX580 + Radeon Pro Render also doesn't work.

But If I create any new file with 2.81a in Blender then Radeon Pro Render works also for that 2.8 created file at that thread. But my 2.8 Donut.blend crashes and shuts down without any message or error message!

I have attached a 2.81a created render (cube.png) which was rendered using Radeon Pro Render.

$\endgroup$
  • $\begingroup$ It may be crashing due to it being in beta. $\endgroup$ – Yohello 1 Jan 1 at 20:12
  • $\begingroup$ But 2.81a isn't in Beta....(As Far As I Know It Got Released in December) And When I made that Donut in 2.8 That wasn't in Beta Either.... Also If I Use 2.8 WIth RPR on that Donut File. it Crashes Too..... $\endgroup$ – Amitrakshar Biszz Jan 2 at 9:01
0
$\begingroup$

The problem is with ProRender. I used Color Ramp with displacement node, that caused the problem while rendering at ProRender version 2.2 for Blender.

They partly fixed the issue, but for some particular cases it will still crash, but they are tryng to fix it.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.