2
$\begingroup$

I'm rendering a transparent cup with water + transparent plate. However, the right bottom part of the shadow seem quite off. It has artifacts in the shadow.

https://imgur.com/a/djoP72f

This is the problematic part enter image description here

Before using the Denoising Data option in View Layer Properties, however it looks kinda ok. It looks like this.

https://imgur.com/a/rX34dZl

So maybe it's a problem of denoising? However, this is part of the tutorial of Blender Guru's Donut Tutorial and he's using the denoising option and it looks just fine.

Here is the blender file just to be sure.


My sampling rate in the renderer is 128 and I'm using Blender 2.8. All the transparent materials are made by Principled BSDF, Transmission 1.0, and Roughness 0.0.

$\endgroup$
  • $\begingroup$ What Blender version are you using? In older versions you had to check "Use transparent shadows" per material to avoid artefacts. $\endgroup$ – Frederik Steinmetz Dec 30 '19 at 13:16
  • $\begingroup$ @FrederikSteinmetz It's unfortunately 2.8 : ( $\endgroup$ – Peter Dec 30 '19 at 13:21
4
$\begingroup$

Denoisers use an algorithm to predict and remove noise (the fireflies). However, when your image gets too noisy, the algorithm will be unable to predict what is supposed to be where (remember it's looking at the pixels and running some sort of math to try and guess what you don't want in the scene, and how to use the surrounding pixels to fix it).

In this case, you're going to need to increase your sample count.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you. I'll try disabling the denoising option and try the sample count to 256 this time. $\endgroup$ – Peter Dec 30 '19 at 14:02
  • $\begingroup$ Well, you don't need to get rid of the denoiser altogether, but I would definitely increase the sample count. If you want a noise-free image without denoisers when dealing with transparent objects, oftentimes your sample count can easily go up into the thousands. $\endgroup$ – stphnl329 Dec 30 '19 at 14:35
  • $\begingroup$ Is that so?? I will keep that in mind. Quick question though, I realized I see a Denoising Data option under View Layer Properties-Passes-Data, and a Denoising option under View Layer Properties-Denoising. Which one should I use? $\endgroup$ – Peter Dec 30 '19 at 14:49
  • $\begingroup$ Try using the Denoise node in the Compositor. Here's a quick tutorial on how to do that: youtube.com/watch?v=Pw-OxOHHu5I PS: If you can't see any nodes in the compositor, check Use Nodes at the top $\endgroup$ – stphnl329 Dec 30 '19 at 14:58
  • $\begingroup$ PS: the video is a bit dated, you don't need an experimental build. $\endgroup$ – stphnl329 Dec 30 '19 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.