0
$\begingroup$

I was running a python script in Blender 2.82 for Manjaro and got this error:

Read prefs: /home/manjaro/.config/blender/2.82/config/userpref.blend
found bundled python: /home/manjaro/Descargas/blender-2.82-e0cd5b980fc5-linux-glibc217-x86_64/2.82/python
Read blend: /home/manjaro/Descargas/blender-2.82-e0cd5b980fc5-linux-glibc217-x86_64/carpeta trabajo blender 2.82/vincent_modify/Vincent to be modify6b81.blend
ERROR (bke.anim_sys): /home/sources/buildbot-x86_64-slave/linux_glibc217_x86_64_cmake/blender.git/source/blender/blenkernel/intern/anim_sys.c:4160 BKE_animsys_eval_driver: invalid driver - pose.bones["lip_low_4_bbone_easeout_R"].rotation_quaternion[1]
ERROR (bke.anim_sys): /home/sources/buildbot-x86_64-slave/linux_glibc217_x86_64_cmake/blender.git/source/blender/blenkernel/intern/anim_sys.c:4160 BKE_animsys_eval_driver: invalid driver - pose.bones["lip_up_4_bbone_easeout_R"].rotation_quaternion[1]
ERROR (bke.anim_sys): /home/sources/buildbot-x86_64-slave/linux_glibc217_x86_64_cmake/blender.git/source/blender/blenkernel/intern/anim_sys.c:4160 BKE_animsys_eval_driver: invalid driver - pose.bones["lip_low_4_bbone_easeout_R"].rotation_quaternion[2]
ERROR (bke.anim_sys): /home/sources/buildbot-x86_64-slave/linux_glibc217_x86_64_cmake/blender.git/source/blender/blenkernel/intern/anim_sys.c:4160 BKE_animsys_eval_driver: invalid driver - pose.bones["lip_low_4_bbone_easeout_R"].rotation_quaternion[3]
ERROR (bke.anim_sys): /home/sources/buildbot-x86_64-slave/linux_glibc217_x86_64_cmake/blender.git/source/blender/blenkernel/intern/anim_sys.c:4160 BKE_animsys_eval_driver: invalid driver - pose.bones["lip_up_4_bbone_easeout_R"].rotation_quaternion[2]
ERROR (bke.anim_sys): /home/sources/buildbot-x86_64-slave/linux_glibc217_x86_64_cmake/blender.git/source/blender/blenkernel/intern/anim_sys.c:4160 BKE_animsys_eval_driver: invalid driver - pose.bones["lip_low_4_bbone_easeout_L"].rotation_quaternion[1]
ERROR (bke.anim_sys): /home/sources/buildbot-x86_64-slave/linux_glibc217_x86_64_cmake/blender.git/source/blender/blenkernel/intern/anim_sys.c:4160 BKE_animsys_eval_driver: invalid driver - pose.bones["lip_up_4_bbone_easeout_L"].rotation_quaternion[1]
ERROR (bke.anim_sys): /home/sources/buildbot-x86_64-slave/linux_glibc217_x86_64_cmake/blender.git/source/blender/blenkernel/intern/anim_sys.c:4160 BKE_animsys_eval_driver: invalid driver - pose.bones["lip_up_4_bbone_easeout_R"].rotation_quaternion[3]
ERROR (bke.anim_sys): /home/sources/buildbot-x86_64-slave/linux_glibc217_x86_64_cmake/blender.git/source/blender/blenkernel/intern/anim_sys.c:4160 BKE_animsys_eval_driver: invalid driver - pose.bones["lip_low_4_bbone_easeout_L"].rotation_quaternion[2]
ERROR (bke.anim_sys): /home/sources/buildbot-x86_64-slave/linux_glibc217_x86_64_cmake/blender.git/source/blender/blenkernel/intern/anim_sys.c:4160 BKE_animsys_eval_driver: invalid driver - pose.bones["lip_up_4_bbone_easeout_L"].rotation_quaternion[2]
ERROR (bke.anim_sys): /home/sources/buildbot-x86_64-slave/linux_glibc217_x86_64_cmake/blender.git/source/blender/blenkernel/intern/anim_sys.c:4160 BKE_animsys_eval_driver: invalid driver - pose.bones["lip_low_4_bbone_easeout_L"].rotation_quaternion[3]
ERROR (bke.anim_sys): /home/sources/buildbot-x86_64-slave/linux_glibc217_x86_64_cmake/blender.git/source/blender/blenkernel/intern/anim_sys.c:4160 BKE_animsys_eval_driver: invalid driver - pose.bones["lip_up_4_bbone_easeout_L"].rotation_quaternion[3]
Traceback (most recent call last):
  File "/home/manjaro/Descargas/blender-2.82-e0cd5b980fc5-linux-glibc217-x86_64/carpeta trabajo blender 2.82/vincent_modify/Vincent to be modify6b81.blend/OpenCVAnimOperator", line 2, in <module>
ModuleNotFoundError: No module named 'imutils'

To be honest,I don't know how to fix it or what it means. The first thing that caught my attention was the "no module named 'imutils'" but it is installed... I tried:

pip3 install imutil

and got:

Requirement already satisfied: imutils in ./.local/lib/python3.8/site-packages (0.5.3)

I also tried:

sudo pip3 install imutil

And got this:

Traceback (most recent call last):
File "/home/manjaro/.local/bin/pip3", line 6, in <module>
from pip._internal.main import main
ModuleNotFoundError: No module named 'pip._internal.main'

And here is where I'm stuck. So if anybody can help me...

$\endgroup$
0
0
$\begingroup$

okay, my first post in blender....

go to directory. (i think you are using 2.82, i am using 2.81)

cd /home/manjaro/Descargas/blender-2.82-e0cd5b980fc5-linux-glibc217-x86_64/2.82/python/bin

./python3.7m -m ensure pip

./python3.7m -m ensurepip

./python3.7m -m pip install --upgrade pip --user

./python3.7m -m pip install opencv-contrib-python numpy --user

thats all i did and i hope your problem should get solve too.

br.. Yaju

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.