I'm trying to add a new keyframe to my timeline, however it doesn't seem to do anything.

I have tried right clicking on the timeline, and then pressed Insert Keyframe. Apparently, that does nothing. There's no new diamond added. It's the same story when I press I .

How do I add a keyframe?

  • 4
    $\begingroup$ Hi. Can you elaborate on what you mean? What do you mean 'nothing happened'? Please add detailed steps of what you did and what you were expecting by using the edit link under your question. $\endgroup$ Commented Dec 28, 2019 at 18:17
  • $\begingroup$ Do you know how to render just a certain parts of the animation? The time line is 0-250, and my animation is short and only from 0-60, I just want to render 0-60, how to do that? $\endgroup$
    – user85150
    Commented Dec 28, 2019 at 18:22
  • 3
    $\begingroup$ This does not answer Ray's question... Anyway, go to Output Properties (printer icon) > Dimensions Tab > Frame End to set the frame range you want to render @user85150 You can also find this property on the top right of your timeline (Start | End). $\endgroup$
    – brockmann
    Commented Dec 28, 2019 at 18:31

4 Answers 4


You have to press [I] while holding your mouse on whatever you want to make a key frame on. The reason that it's like this is because almost anything in blender is animatable. even the buttons. This gives for lots of options and creative possibilities, but makes things a little different from other software.

So if you want to add a keyframe for an object, you select the object, and hold your mouse over the 3d view and press [I]. Alternatively you can go to Object > Animation > Insert Keyframe in the 3d viewport. enter image description here

If you want to add keyframes for an armature, make sure you are in Pose mode of that armature, select the bones you want keyframes for and press [I] while your mouse is hovering the 3D view. enter image description here

You can also animate settings, right click or press [I] over almost any button in blender and there is an option [+ Insert Keyframe] available so this can be added. enter image description here

Bonus: This means you can also animate an object by hovering the transform location in the toolbar panel and inserting a keyframe directly from these buttons. enter image description here


As specified in MrTheRich's answer, Blender requires you to press "i" while you have whatever bones you want to put an keyframe initially. The way you attempted by right-clicking in the timeline only works once the bones is registered inside the timeline. I know that this is kinda of a bummer, but that's how it is.

So, to add a keyframe to a or multiple bones, it goes as this:

• If there are no keyframe registered yet to that or those bones, select the bone(s), hover the mouse onto the 3D view and press "i". Then select what kind of keyframe you want to register. If you're making a video game, I suggest Rot/Loc as the Scale keyframe might not be working properly or at all depending on what engine you use and what type of 3D model files you're exporting the model into afterwards.

• Once a keyframe is registered and set to one or multiple bones, pressing the "add keyframe" in the timeline (as you have attempted) will work, but it will only add a keyframe of the same kind as the one you previously selected.


If Auto Keying is enabled (in the Timeline view's header) pressing I does nothing.

Disable Auto Keying or just move the object to insert a keyframe.


Blender 3.0
Had a problem with trying to insert a keyframe in between two bezier keyframes, I was trying to set a new keyframe when the object was already on the point specified by the curves

Make sure Auto Keying is enabled
Moved it up with G 1
and then back down with G -1

That fixed it for me!


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .