1
$\begingroup$

I am a beginner to Blender and watching this video.

At 8:46 is when my problem occurs, because my sprinkles are appearing beneath the icing.

$\endgroup$
3
  • 1
    $\begingroup$ Hey Wasay! Welcome to the Blender SE! Can you share your blend file here so I can have a look at the problem? $\endgroup$ Dec 27 '19 at 19:09
  • 1
    $\begingroup$ Can you give me your email adress $\endgroup$ Dec 27 '19 at 20:01
  • $\begingroup$ Go here - blend-exchange.giantcowfilms.com Upload your blend file after entering the URL of this question page. You'll get a link which you can copy and paste on your original post by editing it. $\endgroup$ Dec 27 '19 at 20:07
4
$\begingroup$

Welcome to the Blender community!

All you need to do is continue watching that video until the very end :) BlenderGuru addresses that issue.

Edit: I looked at the file you posted, and the short answer I posted above is incorrect.

The reason why your sprinkles are not showing up properly is that you did not apply the Solidify modifier. BlenderGuru did this at the beginning of Level 1: Part 5.

This is important because of particles are created on the original mesh prior to the other modifiers being applied. You can see that below, where the Solidify modifier is adding additional icing that covers the sprinkles.

before/after comparison

To fix this, you'll need to go to the Modifiers tab (the blue wrench) and apply the Solidify modifier. However, when I tried to do this in your file, I received an error due to Multi-user data. This just means that multiple objects have been "linked" together so that if you edit the data for one object, all the objects change.

To fix this, head over to the Object Data Properties tab, which has an icon that looks like a green triangle. Then, press the button labelled "2". The "2" indicates that there are two objects using the data, and pressing it will make this a single-user (unique object).

Make single user copy

Once you've done that, head back to the Modifiers tab, and apply the Solidify modifier. The sprinkles will now be showing up on top of the icing, and you should be ready to continue through the Donut tutorials!

$\endgroup$
2
$\begingroup$

There are quite a few steps you didn't follow according to BlenderGuru.

Before you started sculpting the icing on top of the donut, you forgot to apply the Subdivision Surface and Solidify modifiers for the icing.

The order of the modifiers for the icing are wrong. Solidify should come first on top, followed by Subdivision Surface beneath it (Click on the up and down buttons next to the 'x' on the modifier to change their order. Blender modifiers are always calculated from top to bottom. This also applies to the order in which you apply the modifiers - top first. (Refer to the image below)

If you try to apply them now you'll get an error message saying "Modifiers cannot be applied to multi-user data". This error occurs because you've created a linked duplicate of the icing, which is in the 'Archive' collection.

In order to get your sprinkles to show up on top, you'll need to apply the modifiers first (solidify especially, because the modifier doesn't actually expand more of the object, but rather projects a ghost version of it until you click 'Apply', which is why the sprinkles don't show up on top of the icing.

So here's how you're gonna fix this:-

1.) Right click on your 'Archive' collection and click 'Delete Heirarchy'

2.) Click on the icing. Go to the Modifier tab and place the Solidify modifier on top

3.) Apply the Solidify modifier first, and then the Subdivision modifier

Your icing should now be on top. My suggestion - redo the icing, as it's not as well sculpted as it could be, which I believe was the result of you not having applied the modifiers before sculpting. Rewatch Blender Guru's tutorial and try to follow every step.

Hope this helps :)

enter image description here

$\endgroup$
2
  • $\begingroup$ lol looks like we posted the same thing at the same time {x_x} $\endgroup$
    – stphnl329
    Dec 27 '19 at 22:54
  • 1
    $\begingroup$ Hahahahahha yeah I just noticed! XD $\endgroup$ Dec 27 '19 at 22:55
1
$\begingroup$

I'm currently working through the Donut tutorial using Blender v2.91.0, and I also ran into the same issue where my sprinkles only showed up on the underside of my icing. Sprinkles only on underside of icing

I checked all my normals settings, etc, but nothing fixed my problem. For me, I was finally able to fix this by checking the "Use Modifier Stack" checkbox underneath the "Particle Settings > Emission > Emit From > Use Modifier Stack" settings.

Use Modifier Stack option

After checking the "Use Modifier Stack" checkbox:

Sprinkles on top now too!

$\endgroup$
1
$\begingroup$

I had the same issue and solved it in a different way.

I went back to Weight Paint mode (the one where you paint a heat map) and noticed that the heat was also painted on the bottom surface of the icing.

You can delete or paint it blue again by setting the Weight of the brush to 0 and just smearing around a bit. It should not go through so when you're painting you're only doing the bottom half.

$\endgroup$

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .