0
$\begingroup$

When I try to get shadow from a plane, I always get some gap between the plane and the shadow. If I disable contact shadows the gap is full: enter image description here

When I enable contact shadow it seems like I can get rid of this gap, but no. In some view angles I still see the gap. enter image description here

And even if I set contact shadows values too high, I cannot fully get rid of the gap but also I get many unnecessary artifacts. enter image description here This does not happen in Cycles.

So what should I do to get perfect shadow from plane without any gap and artifacts in Eevee?

$\endgroup$
1
$\begingroup$

Adjust Bias and thickness to your needs. If it's still renders gaps try higher res shadows. An Example: enter image description here

$\endgroup$
  • $\begingroup$ I tried this. Unfortunately, any setting leaves some gap. You can see it if an angle of view is very close to plane edge. So the only some thikness can help get rid of gap, but I need exactly a plane without any thikness for my purpose. $\endgroup$ – Sergey Kravchenko Dec 27 '19 at 9:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.