0
$\begingroup$

This feature was working then i tried rendering it and planes were blank. I tried adding another different image as plane and it doesn't show at all just a black plane. The video i am trying to add is in documents>blender projects>folder>videos, no idea whats happening or what I've done.

enter image description here

enter image description here

$\endgroup$
  • 1
    $\begingroup$ It could be an issue with the codec of the specific video you're using. Try saving the video to a JPG or PNG image sequence and use that instead. You can use the free program Handbrake to save out the images or use a different codec. $\endgroup$ – crazycourier Dec 26 '19 at 20:50
  • $\begingroup$ Thanks, i tried a jpeg and it works but all 3 videos mp4s and avi's all didn't work in cycles but works fine in blender render. My project is made in cycles though, weird problem as it's worked before. $\endgroup$ – Gooniezmedia Dec 26 '19 at 22:53
  • $\begingroup$ Looking closer at the node setup, you have a noodle going from the alpha output of the image node to the fac on the mix node. mp4 and avi codecs do not support alpha. Try connecting the diffuse node directly to the material output and see if it renders. $\endgroup$ – crazycourier Dec 27 '19 at 18:03
  • $\begingroup$ Actually disregard that last comment, I tested that in 2.79 and even without an alpha channel in the video, it doesn't affect it. Although, I'm having no problems $\endgroup$ – crazycourier Dec 27 '19 at 18:18
  • $\begingroup$ thanks for trying, i'm trying it on an old laptop and it works fine but need it to work on my new laptop $\endgroup$ – Gooniezmedia Dec 28 '19 at 21:26
1
$\begingroup$

First change image source from Movie to Single Image or Image Sequence.

enter image description here

In Texture viewport shading mode, image texture for displaying must be active at Node Editor.

Just click on it and it should be appeared.

| improve this answer | |
$\endgroup$
  • $\begingroup$ thanks, Not sure how to do this, i'm a bit lost again, still learning. I'm trying to add a video to a plane, i should have made it clear. I have plane selected and am in texture mode and i think plane is active, still same result. $\endgroup$ – Gooniezmedia Dec 26 '19 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.