0
$\begingroup$

I'm experiencing a weird problem with pose libraries that I'm not really sure how to deal with. I have a rigged character I've been working on for a while now. Today I tried using a pose library to save some poses that I might use in later actions. I added a few poses to the library - so far so good. Then I saved and quit and came back to the file later. I decided I wanted to go and tweak another action I'd made earlier, only to discover it suddenly appears horribly mangled - bones seem to have been displaced to random locations, pulling the mesh apart.. I've tried resetting transforms on every bone and both objects, and made sure there were no accidental keyframes on the character object or the armature object. I tried reverting the blend file, and the action appears to be permanently messed up. When I reset the transforms on all the bones, some of them don't return to the rest position (I've tried resetting transforms a dozen times), and they se

Does anyone know what may have caused this, and if there are any notable steps that must be followed to use a pose library properly? It would be a bit of a show-stopper if I had to re make every action from scratch every time I want to add a few poses to a library.

enter image description here

$\endgroup$
  • $\begingroup$ Not sure if it's that causing the issue, but it's a good habit to apply (Ctrl A) rot and scale both to meshes and armatures after modelling and before parenting, weighting and posing. Not doing that can lead to unexpected behaviours of this kind. $\endgroup$ – josh sanfelici Dec 26 '19 at 10:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.