0
$\begingroup$

I have a character rigged with its hair as a separate mesh, which is the child of the head bone in the armature. I have a soft body simulation running on the hair to make it drape down and move around, and it's working perfectly fine, except occasionally when I click to a frame, the hair will appear noticeably far away from where it should be, only to fix itself after a moment without me making and changes and it appears in the right spot. Everything has already been baked and cached, so it shouldn't be moving around at all. The hair also doesn't respond to the snapping around, so I'm not sure what's related to the simulation and what isn't. There are several other objects which share the same parent as the hair (such as the eyes, eyelids, and mouth) and none of them are jumping around in the same way.

I would be okay with this, except it does the same glitch in renders, without having enough time to fix itself, which leads to almost a third of my frames being worthless. If I go to the frames individually and click render, then they render fine. However, I'm working on a project that will eventually have thousands of frames, and I can't be individually checking for glitches and re-exporting them.

Is there a way to fix the soft body simulation permanently so it doesn't do this at all? I'll include screen shots of what's going on. I'd appreciate any guidance or advice anyone might have!

Glitched frame when first viewed Here's the frame when I first view it.

Glitched frame after a few seconds, now fixed Here's what it should look like, and what it goes back to if I linger on the frame for a few seconds.

$\endgroup$
2
$\begingroup$

Hey it's been a while with no response, so I figure I'll post my alternative in case anyone else sees this with the same issue. While soft body is nice because it updates quickly in real time, that's not a required feature for a project that you'll be rendering to video.

I was able to achieve nearly identical results using a cloth sim, without any glitched frames during renders. I just turned off the soft body, turned on cloth, and used the same vertex group I had for the soft body sim. Then I turned the stiffness down to match the settings I had before and placed the cloth modifier ahead of the subsurface modifier and baked the simulation. This worked for what I needed it to do, and solved the issue of the mesh jumping around and glitching.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.