0
$\begingroup$

I get this Error each time trying to import Adobe Stock OBJ files in to Blender:

Traceback (most recent call last):
  File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_scene_obj\__init__.py", line 145, in execute
    return import_obj.load(context, **keywords)
  File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_scene_obj\import_obj.py", line 1232, in load
    use_image_search, float_func)
  File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_scene_obj\import_obj.py", line 344, in create_materials
    col = (float_func(line_split[1]), float_func(line_split[2]), float_func(line_split[3]))
IndexError: list index out of range

location: <unknown location>:-1

Why is this happening?

$\endgroup$
  • $\begingroup$ Can you please check if this error occurs in Blender 2.81a or the 2.82 alpha? $\endgroup$ – Robert Gützkow Dec 23 '19 at 17:53
  • $\begingroup$ I updated to 2.81a but the same error occurred again. However, 2.82 alpha the error did not occur anymore but the model loaded out funny. Like it is partly transparent in rendered mode and completely black when on solid mode. $\endgroup$ – Jamo Dec 25 '19 at 6:38
  • $\begingroup$ If change the material blend mode from alpha blend to any other then it shows up normally when on rendered preview mode. $\endgroup$ – Jamo Dec 25 '19 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.