Hi and thanks in advance. I have a project in which I can't seem to zoom in enough (anymore) and the pivot point does not seem to work as desired. I have tried setting both the 3d cursor and pivot point to the world origin but it does not clear the problem. No matter which object I select and the try to set the pivot point to, I never see the pivot point anymore and the rotation and mouse movements are all wrong. I would expect to select an object, set the pivot point to the active element and actually be able to see a little dot in the object in one of the Viewport modes.

I started a new project and added a cone beside the default cube and I was able to easily set the pivot point to the cube, and then to the cone and all mouse movement, rotation etc worked as I would expect it to. So I believe I understand the what and how but somehow I must have messed up my larger project.

I did find a post that talked about moving in and out of camera view (numpad 0) could cause a similar type of problem and that using numpad '.' would clear it but that has not worked for me.

Any ideas?


It sounds like the viewport is no longer locked to the 3D cursor to me.

Press "N" to pull up one of the side menus, and switch it over to the view tab. Click on "View Lock" and check if "Lock to 3D cursor" is selected

This is the menu you might want to check:

  • $\begingroup$ Hey stphnl329, that was it! Awesome and thanks. I guess at some point, while trying stuff out I locked to an Object. I removed that and now my pivot point is where I expect it and things work as expected/desired. However if I 'Lock to 3d Cursor' my scene completely disappears and when I uncheck 'Lock to 3d cursor' my scene comes back - and the 3d cursor is at my world origin and at the center of my main object so I would expect 'Lock to 3d cursor' to show my scene exactly how I see it when not 'locked to 3d cursor' $\endgroup$ – Jon Dec 23 '19 at 14:49
  • $\begingroup$ Try pressing the slash key "/". That should return the view to the 3D Cursor $\endgroup$ – stphnl329 Dec 23 '19 at 14:58
  • $\begingroup$ hmm, definitely working as expected/desired now that I am not 'Locked to Object' and the '/' key did get my objects visible even when I 'Lock to 3d Cursor' which is at the center of my main object ...BUT ... if I press '1' (ortho front) my view is is not anywhere near my object - When I check 'Lock to 3d Cursor' and press '1' I cannot see my object, I have to navigate to it. But when 'Lock to 3d cursor is NOT checked '1' takes me right to the 3d cursor and my object. That seems backwards to me. $\endgroup$ – Jon Dec 23 '19 at 15:22
  • $\begingroup$ Just press the "Home" key to recenter the camera on the object anytime :) $\endgroup$ – stphnl329 Dec 23 '19 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.