0
$\begingroup$

I've imported a FBX model (made by someone else in Blender), but the textures are inside the model. Recalculating your and reuploading the textures didn't help.

outside

inside

UPD: the model itself https://drive.google.com/open?id=1Btqvb60qj4HtmpKEWG0E-dG--hYd7dR6

$\endgroup$
  • $\begingroup$ Please share your file so we can see what's going on with it. My first guess is that there's a Geometry node with the Facing attribute somewhere in your shader node tree. $\endgroup$ – PJM Design Dec 23 '19 at 18:52
  • 1
    $\begingroup$ May be the light source is inside of the object. $\endgroup$ – FFeller Dec 23 '19 at 20:01
  • $\begingroup$ @PJM I've added the link $\endgroup$ – SCP701 Dec 24 '19 at 3:43
1
$\begingroup$

You need to enable Backface Culling in the material settings. It is the extra geometry for creating an outline blocking the view.

enter image description here

You can build a custom toon shader. Here is one:

enter image description here

This is for EEVEE only.

If you want you can watch some tutorials on Non-PBR shading. For example https://www.youtube.com/watch?v=E3zHGD8V2IY or https://www.youtube.com/watch?v=dCF29s2FRsQ

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.