3
$\begingroup$

I'm trying to render a glassy flac. The problem is, taht it makes black reflections on sides or corners. I don't know where these reflections come from, almost white world and in the example the flac is in white cube and still there is black left side.

What can I do to get rid of these black spots?

example

$\endgroup$
6
  • 1
    $\begingroup$ I think this is not reflections, but due to refraction! What value did you set for the "IOR" value of the glass shader? I suggest you to try with a value closer 1.0. $\endgroup$
    – Polosson
    Sep 25, 2014 at 10:21
  • $\begingroup$ I used 1.51714 as suggested here link. When I get to 1.2 it's almost gone, but also some of desired details disappear. $\endgroup$
    – Magorr
    Sep 25, 2014 at 10:48
  • 1
    $\begingroup$ blender.stackexchange.com/questions/2558/… $\endgroup$
    – Omar Emara
    Sep 25, 2014 at 11:29
  • $\begingroup$ These are probably shadows from the light. The only way I've found to get rid of this is to disable them. $\endgroup$ Sep 25, 2014 at 17:04
  • 3
    $\begingroup$ Looks to me like a combination of total internal reflection and not enough transmission bounces. Note that this is in someways correct, as if light bounces around inside a piece of glass far enough, it will be absorbed pretty much completely. See e.g. these images $\endgroup$
    – gandalf3
    Sep 25, 2014 at 17:10

3 Answers 3

4
$\begingroup$

In the render properties for cycle find the Light Paths and increase the Transmission value till the dark spots go away.

$\endgroup$
1
$\begingroup$

I had the same issue and found it was due to my glass being shaded smooth. I added an Edge Split modifier and the black areas of refraction went away.

$\endgroup$
0
$\begingroup$

Use transparent instead of glossy when the glossy ray depth is grater than the value of max glossy bounces.nodes

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .