I have a model of a Rook, after applying a sub div modifier and creasing a few edge loops I am left with these curved edges that form the bridges between the edge loops as shown in the image. Auto smooth is enabled. I want the curvature of the upper edge loop to continue. Edge Problem

link to model: https://drive.google.com/open?id=1pOFzSxaiFRGXxxMSYnYX707fe1JY9bKK



  1. The edge is missing a crease, so the Subdivision Modifier deforms it.
  2. You've enabled the On Cage option in the modifier panel, which prevents you from noticing it.
  3. Your model is too low poly, the Subdivision modifier doesn't know which way to curve the edges.


  1. Add a crease to the edge, or add some loopcuts.
  2. Disable the On Cage option - it has no benefit here, only hides real geometry.
  3. Add more geometry, so you can better control the curvature.

enter image description here

Add more geometry.
If you only add loopcuts, you'll need to correct the shape.
It's easier to rebuild the model with more sides.

enter image description here

  • $\begingroup$ I did try the above but got straight edges instead of curved edges that continue the edge loop $\endgroup$ – Kluivert Correia Dec 22 '19 at 7:28
  • $\begingroup$ Adding loop cuts does help either $\endgroup$ – Kluivert Correia Dec 22 '19 at 7:47
  • $\begingroup$ @Kluivert I'm confused, I thought getting rid of curved edges was the goal :). Consider editing your question, so it's clear what is the desired result. $\endgroup$ – Jachym Michal Dec 22 '19 at 8:46
  • 1
    $\begingroup$ Right, I get it now. The On Cage option won't help you there, you need to add more geometry. I'll update my answer on how to get there :). $\endgroup$ – Jachym Michal Dec 22 '19 at 9:53
  • 1
    $\begingroup$ Thanx, It worked! $\endgroup$ – Kluivert Correia Dec 22 '19 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.