I can't seem to select a clip in the sequencer. When I try, all it does is move the scrub point. I don't want to move the scrub point, I want to select the clip. I want to move the clip around. I want to delete the clip. But I can't select the clip!

I have tried ⇧ Shift clicking, ⎈ Ctrl clicking, ⌘ Cmd clicking, ⌥ Opt clicking, and every combination I could think of...


Selecting is done with RMB RMB. Also make sure you click more in the middle of the strip, as the ends of a strip can be selected separately.

enter image description here


Click in the middle of the strip, not the ends with the arrows.

  • A selects/deselects all.
  • B starts Box Select.
  • Nonkeypad Home centers the selected strip.
  • Ctrl +MMB zooms.

It may be easier if the clip is of a manageable size.


Ok, I figured it out. The other answers seemed to assume you were not on a Mac or that you were using a physical mouse. If you have a physical mouse (with more than one button) attached, your RMB RMB should work to select. If not, try checking your mouse settings to make sure a right click is really a right click.

If you are using a multi-touch track pad a two finger click might work. If not go into your trackpad settings to see what combination of presses equals a right mouse button click.

I felt really dumb after figuring this out by accident. I spent a day clicking again and again grumbling against stupid Blender.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.