I don't know if anyone has asked this but I've encountered this problem numerous times on multiple files. When I'm trying to edit a mesh I get this edge that I can't select.
The Problem Here's a better picture of what's going on. It's part of the face, but the edge doesn't show up in the wireframe. I tried deleting the face and it put a hole in my mesh.

  • $\begingroup$ Daniel, Welcome to Blender.stackexchange. I had some difficulty viewing the screen shot you posted, and then when I managed to view the screen shot, I could not tell which edge you were having trouble selecting. Your mileage may vary, and I'm not sure how you're trying to select the edges that are giving you difficulty, but in my own modeling, many of the instances where I cannot select an edge become resolved when I select the vertices at where I think each end of the edge should be with the box or circle tool in wireframe mode, and apply the "remove doubles" tool. [Continued below] $\endgroup$ – brasshat Sep 24 '14 at 4:35
  • $\begingroup$ [Continued from above] Or instead of the "remove doubles" tool, you can deactivate the "limit selection to visible" button in the header of the 3D viewport. $\endgroup$ – brasshat Sep 24 '14 at 4:36
  • $\begingroup$ Thanks for the quick response. It's the two lines at the bottom right of the hilt(the two bluish triangles). They show up as edges but there's no black line connecting the vertices. The edges don't move either. If I pull the faces outward, they disappear, but If I push them inward, the edges reappear. $\endgroup$ – AtomicAquarius Sep 24 '14 at 5:56
  • $\begingroup$ Looks like a non-planar face or two, possibly an ngon, but it's hard to tell in the screenshot. Is it possible you could upload the .blend? $\endgroup$ – gandalf3 Sep 24 '14 at 6:15
  • $\begingroup$ I think Gandalf3 is probably right. What you might try is to switch to face select mode, wireframe view. I would expect here that you should see the activating square for the rectangle, and if select that face, and then delete "faces only", the problem should resolve itself. $\endgroup$ – brasshat Sep 24 '14 at 6:22

It looks as though you have a non-planar face. Since there is no such thing as a curved surface in computer graphics each face gets "triangulated" down to one or more tris (triangles). So even though a face may only have four edges, it is really composed of two tris, separated by a hidden edge. This can cause unpredictability when the face is not planar.

To put an editable edge there you can select the two vertices and hit J to join the two vertices.

Alternatively, you can make the face planar by going to Mesh menu > Clean up > Make Planar Faces.

enter image description here

|improve this answer|||||
  • $\begingroup$ That fixed it, thanks a ton! I didn't know about that. $\endgroup$ – AtomicAquarius Sep 25 '14 at 7:25

I went in circles with this problem, only to realize the edge was a different object. Had separated it from main mesh I don't know how. So i just selected object mode, then selected the edge as an independent object

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.