2
$\begingroup$

I have 3 objects: human model, pants and 1 armature for both. Before I started work on pants, I made few animations for body (run, idle). Initial problem was that the pants partially fall into the character during the run animation. I decided to fix that with shape keys. So I made 18 shape keys which made the pants looks correctly in run animation. But when I change animation in armature, shape keys still affect and when I try to export (.fbx for Unity), shape keys change output animations.

So, how can I use key shapes only for 1 animation?

P.S. I know about cloth modifier and weight painting. Both approaches don't work well in my case.

enter image description here

$\endgroup$
  • $\begingroup$ The shape key's animation is also an action, so you can turn it on/off in the action editor if you select the mesh object. $\endgroup$ – FFeller Dec 16 '19 at 15:09
  • $\begingroup$ @FFeller, I added my screen with blender. I can't find shape keys in action editor, only in shape key editor, but there shape keys turn on/off for all animations. Can you, plz, explain where should I turn them off? $\endgroup$ – Филипп Шабатин Dec 16 '19 at 18:10
  • $\begingroup$ Just create a fake user with the shield icon near the "run_shapes" in the Shape key editor, then click on the X to remove the action from the mesh. Later you can reassign it. $\endgroup$ – FFeller Dec 16 '19 at 19:42
  • $\begingroup$ @FFeller, that disables shape keys for all animations, including running, and I want disable them for all animations except running. $\endgroup$ – Филипп Шабатин Dec 17 '19 at 19:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.