1
$\begingroup$

I was creating a doughnut following a famous Blender tutorial on YouTube. I duplicated the upper part of a Torus and made them into a separate object. At this point, when I added a particle system (hair), the hair lines were facing up.

Then, I deformed the object using the sculpting mode. At this point, if I add a particle system, the hair lines look like below; they are facing downwards. I have searched Google and found answers and posts about moving the origin, but it did not work. Is moving the origin the answer? I am using Blender 2.81.

enter image description here

The project file can be downloaded from this URL: https://filebin.net/pyj0vqo1787i4y1r/test.blend?t=uco3o5we

$\endgroup$
3
  • $\begingroup$ Are your normals flipped? $\endgroup$
    – Moog
    Commented Dec 14, 2019 at 18:57
  • $\begingroup$ @Moog Yes, but I wonder why this happened; I don't remember changing the normal manually. $\endgroup$ Commented Dec 14, 2019 at 19:35
  • $\begingroup$ No idea, I haven't tracked down the reason why it sometimes happens, I think it might be a bug as I have sometimes seen this on loading a blender file. $\endgroup$
    – Moog
    Commented Dec 14, 2019 at 19:59

2 Answers 2

1
$\begingroup$

It seems like a Normal problem. Particles have a reference direction based on the poly surface. Try to flip your normals as you rather a hairy doughnut than a bearded one. This is a good article: https://www.katsbits.com/codex/flip-normals/

$\endgroup$
4
  • $\begingroup$ Flipping the normal solved the problem, but I wonder why this happened in the first place. I had not change the normal. Does using some of the buttons in the Sculpting mode flips the normal? $\endgroup$ Commented Dec 14, 2019 at 19:33
  • $\begingroup$ Something might have happened during the creation process. Usually toruses are initially outward facing normals. Maybe you have negatively set the local Z force for the particle system. You might try to reproduce the error starting all over. $\endgroup$
    – fde-capu
    Commented Dec 14, 2019 at 19:37
  • 1
    $\begingroup$ @Flávio it's helpful to explain how to fix the problem e.g. screenshot of the menu and/or hotkey, external links are generally used for reference and should not substitute for a full answer here. Please read How to Answer for more information. $\endgroup$
    – Moog
    Commented Dec 14, 2019 at 20:01
  • $\begingroup$ Yes. I am fairly new to 2.8 and I know a lot of hotkeys have changed. Is it still simple 'n'? $\endgroup$
    – fde-capu
    Commented Dec 14, 2019 at 20:47
0
$\begingroup$

Solve it by changing the parameter at Solidify Modifier:

Rim: checking both 'Fill' & 'Only Rim'

Still don't know why it works.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .