0
$\begingroup$

Brand new to Blender, total ground-up. I am pretty jazzed about getting MakeHuman and Blender play nicely but can't get any files open in Blender. Specs:

  • System 76 Gazelle lappie
  • Intel® Core i7-7700HQ CPU @ 2.80GHz × 8
  • Intel HD Graphics 630 (Kaby Lake GT2)
  • 64 bit
  • Ubuntu 18.04
  • Blender 2.81 installed from Ubuntu Software Center
  • Java: openjdk version "1.8.0_222"
  • OpenJDK Runtime Environment (build 1.8.0_222-8u222-b10-1ubuntu1~18.04.1-b10)
  • OpenJDK 64-Bit Server VM (build 25.222-b10, mixed mode)

Problem #1 (main:) Blender opens and appears to run fine but when I click on any sub - menus that interact with the file system Blender shuts down completely. File->Open and Help->Save System Info are two examples. This is also true of the startup splash screen, the little folder/open icon brings down the house.

I can navigate around in the GUI a little, but my first goal is to integrate MakeHuman with Blender and can't get any files open.

Problem #2: Instructions for the MHX2 setup in MakeHuman requires some files dumped into Blender config and plugin directories. I've searched around and none of these directories can be found anywhere on my system:

https://docs.blender.org/manual/en/dev/advanced/blender_directory_layout.html

There is also no .blender plugin directory on my system as suggested here:

https://bitbucket.org/Diffeomorphic/mhx2-makehuman-exchange/src/default/

Is it my own fault for using the Software Center? :-D I went through the documentation site and could find no PPA link, do I need to build it from source myself?

Edit #1: Thank you for your replies, I guess I forgot to indicate notify of thread replies. Below is some more information. There are two versions in the Ubuntu Software center, initially I installed 2.81; purged and installed the other version 2.79. This version does run the file dialog, but the only directory now in .config is 2.81. (????) I could not successfully install the import_runtime_mhx add on (tried several locations, MakeHuman add on does not appear in User Preferences,) so I uninstalled it and re-installed 2.81 in the software center (install from .deb as suggested is next.) I tailed the syslog. On opening Blender:

Dec 14 13:47:13 [my computer name] unity-panel-ser[3228]: menus_destroyed: assertion 'IS_WINDOW_MENU(wm)' failed
Dec 14 13:47:23 [my computer name] compiz[3205]: /run/user/1000/snap.blender/gvfs/ non-existent directory
Dec 14 13:47:23 [my computer name] compiz[3205]: Read prefs: /home/bill/.config/blender/2.81/config/userpref.blend
Dec 14 13:47:23 [my computer name] compiz[3205]: found bundled python: /snap/blender/34/2.81/python

As soon as I hit file->Open, bang, program closes and this is the result:

Dec 14 13:48:00 [my computer name] compiz[3205]: /run/user/1000/snap.blender/gvfs/ non-existent directory
Dec 14 13:48:00 [my computer name] compiz[3205]: message repeated 2 times: [ /run/user/1000/snap.blender/gvfs/ non-existent directory]
Dec 14 13:48:00 [my computer name] compiz[3205]: blender: src/intel/genxml/gen9_pack.h:72: __gen_uint: Assertion `v <= max' failed.
Dec 14 13:48:00 [my computer name] bamfdaemon[2990]: Got an X error: BadWindow (invalid Window parameter)
Dec 14 13:48:00 [my computer name] bamfdaemon[2990]: message repeated 5 times: [ Got an X error: BadWindow (invalid Window parameter)]
Dec 14 13:48:00 [my computer name] unity-panel-ser[3228]: menus_destroyed: assertion 'IS_WINDOW_MENU(wm)' failed
Dec 14 13:48:00 [my computer name] unity-panel-ser[3228]: menus_destroyed: assertion 'IS_WINDOW_MENU(wm)' failed
Dec 14 13:48:00 [my computer name] window-stack-bridge[2975]: Could not get window property "_GTK_WINDOW_OBJECT_PATH" "/org/ayatana/bamf/window/58720298"
Dec 14 13:48:00 [my computer name] window-stack-bridge[2975]: Could not get window property "_UNITY_OBJECT_PATH" "/org/ayatana/bamf/window/58720298"
Dec 14 13:48:00 [my computer name] hud-service[3552]: #033[31mvoid DBusMenuImporter::slotGetLayoutFinished(QDBusPendingCallWatcher*)#033[0m: "No such interface 'com.canonical.dbusmenu' on object at path /org/ayatana/bamf/window/58720298"

Either some dependency is not installed in my environment or the 2.81 version in the Software center has a problem. Off to give a try at installing from source.

Edit #2: Installed 2.81 from source, same result with almost the same errors below. At first it gave me a PHP mbstring.so error (which is installed) so I deleted the config/blender/2.81 directory, restarted Blender. The startup was different but still throws errors and crashes. I'm going to try working with v 2.79, see if I can figure out where the plugins go. :-\

Dec 14 14:14:01 [my computer name] org.gnome.Nautilus[2680]: blender: src/intel/genxml/gen9_pack.h:72: __gen_uint: Assertion `v <= max' failed.
Dec 14 14:14:01 [my computer name] bamfdaemon[2990]: Got an X error: BadWindow (invalid Window parameter)
Dec 14 14:14:01 [my computer name] bamfdaemon[2990]: message repeated 6 times: [ Got an X error: BadWindow (invalid Window parameter)]
Dec 14 14:14:01 [my computer name] unity-panel-ser[3228]: menus_destroyed: assertion 'IS_WINDOW_MENU(wm)' failed

Edit #3: Installed 2.79 from source and figured out plugins/addons were in /usr/share/scripts/addons and added the MakeHuman import runtime plugin, set permissions as all the other addins in that directory, and now the MakeHuman addon shows up and is selectable in preferences->addons.

Makehuman just doesn't doesn't show up in the import file list. Almost there.

Realized I had some issues with makehuman export (it was throwing exeptions on export I hadn't noticed,) installed 1.2 which I know is experimental and now Makehuman export works in multiple formats, so I know I've almost got it.

Edit #4: HA! Found it, there is a tab in the leftmost side of the pane. Still would like to resolve 2.81 issues.

MHX2 import

$\endgroup$
  • 1
    $\begingroup$ Welcome to Blender stack exchange. If you can consistently reproduce the bug then please report it to the bug tracker developer.blender.org/maniphest/task/edit/form/1 $\endgroup$ – Samir Rahamtalla Dec 13 '19 at 8:29
  • $\begingroup$ Try to use Snap install or just unpack latest build. Dirrectory "$HOME/.config/blender/" should appears with first run. $\endgroup$ – RUben Dec 13 '19 at 8:50
  • $\begingroup$ For 2.81, try to update your graphics driver using the most recent official one provided by Intel. $\endgroup$ – Robert Gützkow Dec 14 '19 at 23:14
  • $\begingroup$ Thank you, I will check, but if you look at the syslog entries the errors are not typical of graphics problems. I can run 2.81/2.82 and work in the interface, it is only when I attempt to do File->Open the program crashes. $\endgroup$ – SdBill Dec 15 '19 at 15:59
  • $\begingroup$ Still at it, graphics drivers updated and attempted re-install, same errors. Do the log entries above tell anyone anything? $\endgroup$ – SdBill Dec 21 '19 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.